summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-14 10:46:24 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-17 10:36:56 +0100
commit7eb0d668b9ec964258285a7c15b70df3de0b766c (patch)
tree4175a8c9d31b9672b5be20d2d88f4af752670104 /dev-vcs
parentdev-util/maturin: Use new cargo_target_dir helper (diff)
downloadgentoo-7eb0d668b9ec964258285a7c15b70df3de0b766c.tar.gz
gentoo-7eb0d668b9ec964258285a7c15b70df3de0b766c.tar.bz2
gentoo-7eb0d668b9ec964258285a7c15b70df3de0b766c.zip
dev-vcs/git-absorb: Use new cargo_target_dir helper
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-absorb/git-absorb-0.6.11-r1.ebuild2
-rw-r--r--dev-vcs/git-absorb/git-absorb-0.6.13-r1.ebuild2
-rw-r--r--dev-vcs/git-absorb/git-absorb-0.6.13.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-vcs/git-absorb/git-absorb-0.6.11-r1.ebuild b/dev-vcs/git-absorb/git-absorb-0.6.11-r1.ebuild
index ae2ac7412a63..8bc9867defb2 100644
--- a/dev-vcs/git-absorb/git-absorb-0.6.11-r1.ebuild
+++ b/dev-vcs/git-absorb/git-absorb-0.6.11-r1.ebuild
@@ -96,7 +96,7 @@ QA_FLAGS_IGNORED="usr/bin/${PN}"
src_compile() {
cargo_src_compile
- GIT_ABSORB_BIN="target/$(usex debug debug release)/${PN}"
+ GIT_ABSORB_BIN="$(cargo_target_dir)/${PN}"
# Prepare shell completion generation
mkdir completions || die
diff --git a/dev-vcs/git-absorb/git-absorb-0.6.13-r1.ebuild b/dev-vcs/git-absorb/git-absorb-0.6.13-r1.ebuild
index 11e455e2c06d..133c6490b757 100644
--- a/dev-vcs/git-absorb/git-absorb-0.6.13-r1.ebuild
+++ b/dev-vcs/git-absorb/git-absorb-0.6.13-r1.ebuild
@@ -132,7 +132,7 @@ src_compile() {
cargo_src_compile
- GIT_ABSORB_BIN="target/$(usex debug debug release)/${PN}"
+ GIT_ABSORB_BIN="$(cargo_target_dir)/${PN}"
# Prepare shell completion generation
mkdir completions || die
diff --git a/dev-vcs/git-absorb/git-absorb-0.6.13.ebuild b/dev-vcs/git-absorb/git-absorb-0.6.13.ebuild
index 116da04f2de9..2b900da6e9b8 100644
--- a/dev-vcs/git-absorb/git-absorb-0.6.13.ebuild
+++ b/dev-vcs/git-absorb/git-absorb-0.6.13.ebuild
@@ -124,7 +124,7 @@ QA_FLAGS_IGNORED="usr/bin/${PN}"
src_compile() {
cargo_src_compile
- GIT_ABSORB_BIN="target/$(usex debug debug release)/${PN}"
+ GIT_ABSORB_BIN="$(cargo_target_dir)/${PN}"
# Prepare shell completion generation
mkdir completions || die