summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-28 15:06:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-28 16:00:19 +0200
commitb1b706420ef2ebe61400980fa5435ccb196cf1e5 (patch)
treeeb95763a1ec7547db68f4eb3a4b0cba2e70ac86e /dev-vcs
parentdev-libs/bglibs: destabilize 2.04-r1 for ~ppc (diff)
downloadgentoo-b1b706420ef2ebe61400980fa5435ccb196cf1e5.tar.gz
gentoo-b1b706420ef2ebe61400980fa5435ccb196cf1e5.tar.bz2
gentoo-b1b706420ef2ebe61400980fa5435ccb196cf1e5.zip
dev-vcs/pre-commit: bump to 3.7.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.7.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 9475fcf6da6f..04935f4b042e 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1,3 @@
DIST pre-commit-3.6.0.gh.tar.gz 268891 BLAKE2B 42c52bcd320defe877fdce51af972e177e26956c2baba5e04e9441d7a99fcdc6467dc7913b21f9300efe9ca821c7d06c8d972f3fb79f10f2212dbecb3299040a SHA512 4997dfe15d262b8d0c6de711b2543162fffe14f24ce41d3a3ba2014354861ef72eb3a9cc115125ed57ef3c25a12886f858189d684d343252ad8f46cc0c364935
DIST pre-commit-3.7.0.gh.tar.gz 269999 BLAKE2B 9ca1b2279e1ed753a09c3da83f6de19fc9b36821ba6f642962b9be1da29894e3260c48a2cdb582eb5331543fa6c7e9065d799fde7ab4e84dd54032c2ff84e4a7 SHA512 2a238e74ce2f080914e4403b7ce7b8dbd2a257a736d8292e2ec299c8015d3c4611e51f4be1a95ff2bd29db4888f6997e335346931567e943a8b5d78be7c14725
+DIST pre-commit-3.7.1.gh.tar.gz 270138 BLAKE2B da21e8c05b722985273554bd455d2ea0c113206eb4924c826532b5135805eca143441a237e516fad1275b4c9886d53cb3757d5fefd53613e1f1a1b4da8d7847d SHA512 ffb7606b1706d5e9f46bdffbe20420e6fd4241f6a402740e02f6d8a0e87f29201a20ab92d89fd7ed77f3df31ada6f157837beac9defab7f35ebabf85d47399e8
diff --git a/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild b/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild
new file mode 100644
index 000000000000..88174070951e
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL="ON"
+DISTUTILS_USE_PEP517="setuptools"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/
+ https://github.com/pre-commit/pre-commit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')
+"
+# coreutils requirement, see bug #885559
+BDEPEND="
+ sys-apps/coreutils[-multicall]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.1.1-tests_git_file_transport.patch" )
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+EPYTEST_DESELECT=(
+ # All of these require a boatload of dependencies (e.g. Conda, Go, R and
+ # more) in order to run and while some of them do include
+ # "skip if not found" logic, most of them do not.
+ tests/languages/
+ tests/repository_test.py
+
+ # These three consistently fail with
+ # Calling "git rev-parse" fails with "fatal:
+ # not a git repository (or any of the parent directories): .git".
+ # including with the sandbox disabled.
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+
+ # These two fail if pre-commit is already installed (Bug #894502)
+ tests/commands/install_uninstall_test.py::test_environment_not_sourced
+ tests/commands/install_uninstall_test.py::test_installed_from_venv
+)
+
+distutils_enable_tests pytest