summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-05-28 15:14:32 +0200
committerUlrich Müller <ulm@gentoo.org>2023-05-29 09:57:54 +0200
commit5c5b475068cce291f3bcaad358153b97600eef45 (patch)
tree6fa12264d655eeead904b7f1787f7a4e7992bd6f /eclass/autotools.eclass
parentautotools.eclass: Downgrade eqawarn for renaming configure.in (diff)
downloadgentoo-5c5b475068cce291f3bcaad358153b97600eef45.tar.gz
gentoo-5c5b475068cce291f3bcaad358153b97600eef45.tar.bz2
gentoo-5c5b475068cce291f3bcaad358153b97600eef45.zip
autotools.eclass: Allow running the tools only in src_prepare
Running them in src_unpack made sense only in EAPIs 0 and 1. Fixes: 18fda95cea306efe8009d1100195225acd8f8756 Reviewed-by: Sam James <sam@gentoo.org> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 3a040b863eea..7b94efc225fe 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -560,7 +560,7 @@ autotools_run_tool() {
shift
done
- if [[ ${EBUILD_PHASE_FUNC} != "src_unpack" && ${EBUILD_PHASE_FUNC} != "src_prepare" ]] ; then
+ if [[ ${EBUILD_PHASE_FUNC} != "src_prepare" ]] ; then
eqawarn "Running '${1}' in ${EBUILD_PHASE_FUNC} phase"
fi