summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-13 23:18:56 +0100
committerSam James <sam@gentoo.org>2023-04-13 23:20:23 +0100
commit85db50a7c626a1844c8eb2d03051c8c5d320c205 (patch)
treebc3afddedcc57ff43a10d7b55efd8baad7209626 /eclass
parentmedia-gfx/gnome-screenshot: Fix build without Python native-symlinks (diff)
downloadgentoo-85db50a7c626a1844c8eb2d03051c8c5d320c205.tar.gz
gentoo-85db50a7c626a1844c8eb2d03051c8c5d320c205.tar.bz2
gentoo-85db50a7c626a1844c8eb2d03051c8c5d320c205.zip
toolchain.eclass: enhance USE=debug for more checking
We now do --enable-checking=yes,extra,rtl after discussion in #gcc for USE=debug. If rtl is too slow, we can do just yes,etra. We've actually found yet another bug with our general change for snapshots to start using checking, too: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109506. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass5
1 files changed, 4 insertions, 1 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 0a5e2e1e50aa..1f32e4a9cda3 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1072,8 +1072,11 @@ toolchain_src_configure() {
# Non-released versions get extra checks, follow configure.ac's default to for those.
if ! grep -q "experimental" gcc/DEV-PHASE ; then
# The "release" keyword is new to 4.0. bug #551636
+ # After discussing in #gcc, we concluded that =yes,extra,rtl makes
+ # more sense when a user explicitly requests USE=debug. If rtl is too slow,
+ # we can change this to yes,extra.
local off=$(tc_version_is_at_least 4.0 && echo release || echo no)
- confgcc+=( --enable-checking="${GCC_CHECKS_LIST:-$(usex debug yes ${off})}" )
+ confgcc+=( --enable-checking="${GCC_CHECKS_LIST:-$(usex debug yes,extra,rtl ${off})}" )
fi
fi