summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-12-15 19:13:09 +0100
committerSebastian Pipping <sping@gentoo.org>2017-12-15 19:13:29 +0100
commit82d9fc239fd1dc4a4e2bd0b5a6443ef54fcf4b92 (patch)
tree00c4663d9bd130a30162d990cad3473b867acaf0 /games-board/gambit/gambit-1.0.4.ebuild
parentwww-servers/tomcat: version bump for slot 8 (diff)
downloadgentoo-82d9fc239fd1dc4a4e2bd0b5a6443ef54fcf4b92.tar.gz
gentoo-82d9fc239fd1dc4a4e2bd0b5a6443ef54fcf4b92.tar.bz2
gentoo-82d9fc239fd1dc4a4e2bd0b5a6443ef54fcf4b92.zip
games-board/gambit: 1.0.4
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'games-board/gambit/gambit-1.0.4.ebuild')
-rw-r--r--games-board/gambit/gambit-1.0.4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-board/gambit/gambit-1.0.4.ebuild b/games-board/gambit/gambit-1.0.4.ebuild
new file mode 100644
index 000000000000..28abd503a2c2
--- /dev/null
+++ b/games-board/gambit/gambit-1.0.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD=true
+inherit cmake-utils
+
+MY_P="${P^}"
+
+DESCRIPTION="Qt-based chess application + engine \"gupta\""
+HOMEPAGE="https://sourceforge.net/projects/gambitchess/"
+SRC_URI="mirror://sourceforge/project/${PN}chess/${MY_P}/${MY_P}-src.tar.xz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ media-libs/mesa
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ENABLE_UPDATE_CHECKER=OFF
+ -DCONFIG_GUPTA_ENGINE_DIRECTORY=/usr/bin
+ -DCONFIG_RESOURCE_PATH_PREFIX=/usr/share/${PN}/
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ emake -C engine/gupta VERBOSE=1 STRIP=/bin/true CFLAGS_RELEASE= release
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r data/*
+
+ doicon artwork/icons/${PN}/${PN}.svg
+ make_desktop_entry ${PN}chess ${PN^} ${PN} Game
+ dodoc doc/contributors.txt
+
+ dobin engine/gupta/gupta
+ dobin ${PN}chess
+}