summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2024-11-15 22:12:39 -0500
committerMaciej Barć <xgqt@gentoo.org>2024-11-17 17:26:46 +0100
commita70cfc5d2fffded77dc7d6d4a4f212efbf43c8f6 (patch)
tree465b6f7d1ad2cbbe4c37de2a77084b0e24c5846c /games-emulation
parentprofiles/arch/powerpc/ppc32: mask sys-fs/lvm2[thin] (diff)
downloadgentoo-a70cfc5d2fffded77dc7d6d4a4f212efbf43c8f6.tar.gz
gentoo-a70cfc5d2fffded77dc7d6d4a4f212efbf43c8f6.tar.bz2
gentoo-a70cfc5d2fffded77dc7d6d4a4f212efbf43c8f6.zip
games-emulation/melonds: update live
- Update to use Qt6 as is now upstream default. - Pass -DUSE_SYSTEM_LIBSLIRP to use system libslirp. - The filter-lto and -fno-strict-aliasing appear to be due to an issue from 2022 which appears to no longer be applicable since there has been some heavy refactoring. Remove them. Bug: https://bugs.gentoo.org/858710 Signed-off-by: Violet Purcell <vimproved@inventati.org> Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index e20ccdc8096e..088c19006bc0 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
REAL_PN="melonDS"
REAL_P="${REAL_PN}-${PV}"
-inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="http://melonds.kuribo64.net
@@ -30,11 +30,9 @@ IUSE="+jit +opengl wayland"
RDEPEND="
app-arch/libarchive
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
+ dev-qt/qtbase:6[network,opengl,widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtsvg:6
media-libs/libsdl2[sound,video]
net-libs/enet:=
net-libs/libpcap
@@ -64,19 +62,13 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be extracted from devices or found somewhere on the Internet ;-)"
-src_prepare() {
- filter-lto
- append-flags -fno-strict-aliasing
-
- cmake_src_prepare
-}
-
src_configure() {
local -a mycmakeargs=(
-DBUILD_SHARED_LIBS="OFF"
-DENABLE_JIT="$(usex jit)"
-DENABLE_OGLRENDERER="$(usex opengl)"
-DENABLE_WAYLAND="$(usex wayland)"
+ -DUSE_SYSTEM_LIBSLIRP=ON
)
cmake_src_configure
}