summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-09-22 09:26:38 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-11-02 14:46:00 +0200
commite72b73c3a0aaa42bfbdda67b63284d20c9ff5009 (patch)
tree613231bce0e7adc2f6d84f698a1adb2649f643a7 /games-emulation
parentgames-emulation/sameboy-jg: add 0.16.6 (diff)
downloadgentoo-e72b73c3a0aaa42bfbdda67b63284d20c9ff5009.tar.gz
gentoo-e72b73c3a0aaa42bfbdda67b63284d20c9ff5009.tar.bz2
gentoo-e72b73c3a0aaa42bfbdda67b63284d20c9ff5009.zip
games-emulation/sameboy-jg: drop 0.16.2-r1
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sameboy-jg/Manifest1
-rw-r--r--games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch115
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild54
3 files changed, 0 insertions, 170 deletions
diff --git a/games-emulation/sameboy-jg/Manifest b/games-emulation/sameboy-jg/Manifest
index 46b75ec94dac..eae0f137b0eb 100644
--- a/games-emulation/sameboy-jg/Manifest
+++ b/games-emulation/sameboy-jg/Manifest
@@ -1,3 +1,2 @@
-DIST sameboy-0.16.2.tar.bz2 3556441 BLAKE2B 0972cb8ba200d8ac95a3d66e3b671c1adeeea71eebb4202b1985f7f72edebd42886aac48040bf034dab8d93fd52d15165551ee8dfaf6870a59ca7f574fc99e0f SHA512 bd456e248ec2d6ea0e8b017b705c829c6a94b1f7fe734769a86774c4b6983278cc5b4d61fdf8164844545bbd250b3c4f1fe725046ac7edb301268291d907f39f
DIST sameboy-0.16.5.tar.bz2 4143349 BLAKE2B e56df9bd38a550a78a0f30ab0259b3b11e7af4bc14f0c8a7a51de34af49eac40f09c57b54ce5640ee697eaf8a3b586d0390bebc6f25ddf44ced4a65c7b8f3476 SHA512 e0f463f77236196e00834aa0e814e4cfe78947da73310bb37c23e5a0a7644015467c646825971c0ef6b10c7ba8c058589729271eeacf089ff6d5cad188f2c246
DIST sameboy-0.16.6.tar.bz2 4153538 BLAKE2B e670ba2ee3240b235d776c5b9a55b5b16dc692c63f3c6d8d03eb56c832c655d6782221afb1028b15a0af6b30ac398c7828e8759b8766ce19cd0064815c8890b3 SHA512 355674a3c4b612cf6b03c094cd3067224779d50789599e0fa7dfc3843201d140befc2058c1bd461e8cab11c5ebbbdb8fceaf4b5feee86a59bd49a50b808dca31
diff --git a/games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch b/games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch
deleted file mode 100644
index f1c82ef78ea6..000000000000
--- a/games-emulation/sameboy-jg/files/sameboy-jg-0.16.2-strict-aliasing.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-https://bugs.gentoo.org/926077
-https://github.com/LIJI32/SameBoy/pull/593
-https://gitlab.com/jgemu/sameboy/-/merge_requests/50
-https://gitlab.com/jgemu/sameboy/-/commit/6a283f65cc4b9ee4896942afde745fa67e612fd3
-https://gitlab.com/jgemu/sameboy/-/commit/9067678fe0160fe5c2f10a7f6271f8293d5150d1
-
-From 6a283f65cc4b9ee4896942afde745fa67e612fd3 Mon Sep 17 00:00:00 2001
-From: Lior Halphon <LIJI32@gmail.com>
-Date: Sat, 9 Mar 2024 11:08:01 -0800
-Subject: [PATCH 1/2] Avoid strict aliasing violations. Closes #593
-
-Backported from:
-
-https://github.com/LIJI32/SameBoy/commit/8739da61c013e20e1cc94f0619c622a65c713408
----
- Core/apu.c | 4 ++--
- Core/apu.h | 11 +++++++++++
- Makefile | 2 +-
- 3 files changed, 14 insertions(+), 3 deletions(-)
-
-diff --git a/Core/apu.c b/Core/apu.c
-index e621e82a..0f0ed16b 100644
---- a/Core/apu.c
-+++ b/Core/apu.c
-@@ -100,7 +100,7 @@ static void update_sample(GB_gameboy_t *gb, GB_channel_t index, int8_t value, un
- output.left = output.right = 0;
- }
-
-- if (*(uint32_t *)&(gb->apu_output.current_sample[index]) != *(uint32_t *)&output) {
-+ if (gb->apu_output.current_sample[index].packed != output.packed) {
- refresh_channel(gb, index, cycles_offset);
- gb->apu_output.current_sample[index] = output;
- }
-@@ -131,7 +131,7 @@ static void update_sample(GB_gameboy_t *gb, GB_channel_t index, int8_t value, un
- if (likely(!gb->apu_output.channel_muted[index])) {
- output = (GB_sample_t){(0xF - value * 2) * left_volume, (0xF - value * 2) * right_volume};
- }
-- if (*(uint32_t *)&(gb->apu_output.current_sample[index]) != *(uint32_t *)&output) {
-+ if (gb->apu_output.current_sample[index].packed != output.packed) {
- refresh_channel(gb, index, cycles_offset);
- gb->apu_output.current_sample[index] = output;
- }
-diff --git a/Core/apu.h b/Core/apu.h
-index c8700c80..15b54a87 100644
---- a/Core/apu.h
-+++ b/Core/apu.h
-@@ -25,11 +25,22 @@
-
- /* APU ticks are 2MHz, triggered by an internal APU clock. */
-
-+#ifdef GB_INTERNAL
-+typedef union
-+{
-+ struct {
-+ int16_t left;
-+ int16_t right;
-+ };
-+ uint32_t packed;
-+} GB_sample_t;
-+#else
- typedef struct
- {
- int16_t left;
- int16_t right;
- } GB_sample_t;
-+#endif
-
- typedef struct
- {
-diff --git a/Makefile b/Makefile
-index c25f38b2..bc239893 100644
---- a/Makefile
-+++ b/Makefile
-@@ -164,7 +164,7 @@ endif
-
- # These must come before the -Wno- flags
- WARNINGS += -Werror -Wall -Wno-unknown-warning -Wno-unknown-warning-option -Wno-missing-braces
--WARNINGS += -Wno-nonnull -Wno-unused-result -Wno-strict-aliasing -Wno-multichar -Wno-int-in-bool-context -Wno-format-truncation
-+WARNINGS += -Wno-nonnull -Wno-unused-result -Wno-multichar -Wno-int-in-bool-context -Wno-format-truncation
-
- # Only add this flag if the compiler supports it
- ifeq ($(shell $(CC) -x c -c $(NULL) -o $(NULL) -Werror -Wpartial-availability 2> $(NULL); echo $$?),0)
---
-GitLab
-
-
-From 9067678fe0160fe5c2f10a7f6271f8293d5150d1 Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Sat, 9 Mar 2024 11:08:57 -0800
-Subject: [PATCH 2/2] build: remove -Wno-strict-aliasing + add
- -Wno-missing-braces
-
-Upstream also uses -Wno-missing-braces
-
-See: https://github.com/LIJI32/SameBoy/pull/597
----
- jollygood/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/jollygood/Makefile b/jollygood/Makefile
-index a0bd24b3..b1c22384 100644
---- a/jollygood/Makefile
-+++ b/jollygood/Makefile
-@@ -17,7 +17,7 @@ FLAGS_PB12 := -Os -std=c99
- DEFS := -D_GNU_SOURCE -DGB_INTERNAL -DGB_DISABLE_REWIND -DGB_DISABLE_DEBUGGER \
- -DGB_VERSION=\"$(VERSION)\"
-
--WARNINGS := -Wall -Wno-strict-aliasing -Wno-multichar -Wno-unused-result
-+WARNINGS := -Wall -Wno-missing-braces -Wno-multichar -Wno-unused-result
- WARNINGS_PB12 := -Wall -Wextra -Wshadow
-
- # Only relative include paths are used in sameboy
---
-GitLab
-
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild
deleted file mode 100644
index e417d12d3618..000000000000
--- a/games-emulation/sameboy-jg/sameboy-jg-0.16.2-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_PN=${PN%-*}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Jolly Good Port of SameBoy"
-HOMEPAGE="https://gitlab.com/jgemu/sameboy"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
-else
- SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="1"
-
-DEPEND="
- media-libs/jg:1=
-"
-RDEPEND="
- ${DEPEND}
- games-emulation/jgrf
-"
-BDEPEND="
- >=dev-util/rgbds-0.6.0
- virtual/pkgconfig
-"
-
-PATCHES=(
- # https://bugs.gentoo.org/926077
- "${FILESDIR}"/${P}-strict-aliasing.patch
-)
-
-src_compile() {
- emake -C jollygood \
- CC="$(tc-getCC)" \
- CC_FOR_BUILD="$(tc-getBUILD_CC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- emake -C jollygood install \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}"/usr \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}