summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/sound-of-sorting
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/sound-of-sorting')
-rw-r--r--games-misc/sound-of-sorting/Manifest2
-rw-r--r--games-misc/sound-of-sorting/metadata.xml8
-rw-r--r--games-misc/sound-of-sorting/sound-of-sorting-0.6.3.ebuild20
-rw-r--r--games-misc/sound-of-sorting/sound-of-sorting-0.6.5.ebuild20
4 files changed, 50 insertions, 0 deletions
diff --git a/games-misc/sound-of-sorting/Manifest b/games-misc/sound-of-sorting/Manifest
new file mode 100644
index 000000000000..58e6cdd0a8ff
--- /dev/null
+++ b/games-misc/sound-of-sorting/Manifest
@@ -0,0 +1,2 @@
+DIST sound-of-sorting-0.6.3.tar.bz2 135529 SHA256 1a81398391e322c2b9939153d27e638f11f2472fbd50b4def83ae58a68bc17af SHA512 b8b2cf628ccf8092e8a8e37caea2d4a865ffdebc0d140ad42db67dbead923921538bd530a08f339baeaace03f2ec426454f2907689d486332699b805adfafdcd WHIRLPOOL 54dfbf6c70612a85c40769e5c72404f3c9208af28cef3fe4ad35228d84583d88d61008b533e0deef69aca9459b5aa86ad9a8e50c4f2981374b0ee4f4bd1e75ca
+DIST sound-of-sorting-0.6.5.tar.bz2 144446 SHA256 937c9f9b53289cf80283cfc64afd96a4b9a146b142e36eba5dfdaf0a63ef4ada SHA512 c0dc8761ac8c110d4c516e47dd2dc472714ed9b5d09d1401f11db019abd8933dd5172c540fdb1afc8b3f3b87f0c8d0fa33ffdd4eab6ed1044ed05b704412e34f WHIRLPOOL a29693e9b87b845dceb6cfe77974af204b921df43eb76a5fdf6166eedc069daee9507265de825838b5f89f033edb7af41b23e8741cd14081753896439afdf25e
diff --git a/games-misc/sound-of-sorting/metadata.xml b/games-misc/sound-of-sorting/metadata.xml
new file mode 100644
index 000000000000..1e7587374fdf
--- /dev/null
+++ b/games-misc/sound-of-sorting/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-misc/sound-of-sorting/sound-of-sorting-0.6.3.ebuild b/games-misc/sound-of-sorting/sound-of-sorting-0.6.3.ebuild
new file mode 100644
index 000000000000..3c70c50c944a
--- /dev/null
+++ b/games-misc/sound-of-sorting/sound-of-sorting-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Visualization and Audibilization of Sorting Algorithms"
+HOMEPAGE="http://panthema.net/2013/sound-of-sorting/"
+SRC_URI="http://panthema.net/2013/sound-of-sorting/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ x11-libs/wxGTK"
+RDEPEND="${DEPEND}"
diff --git a/games-misc/sound-of-sorting/sound-of-sorting-0.6.5.ebuild b/games-misc/sound-of-sorting/sound-of-sorting-0.6.5.ebuild
new file mode 100644
index 000000000000..8c1a7fa95bde
--- /dev/null
+++ b/games-misc/sound-of-sorting/sound-of-sorting-0.6.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Visualization and Audibilization of Sorting Algorithms"
+HOMEPAGE="http://panthema.net/2013/sound-of-sorting/"
+SRC_URI="http://panthema.net/2013/sound-of-sorting/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ x11-libs/wxGTK"
+RDEPEND="${DEPEND}"