summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 21:59:07 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 21:59:07 +0200
commit0fe5dbcb6480392e8c7b84cbdeecc32a5c29d571 (patch)
treeea66c7caa3f23e3dc41c234440ba7868023103a3 /games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild
parentdev-util/xdelta: [QA] Do not install static archives (diff)
downloadgentoo-0fe5dbcb6480392e8c7b84cbdeecc32a5c29d571.tar.gz
gentoo-0fe5dbcb6480392e8c7b84cbdeecc32a5c29d571.tar.bz2
gentoo-0fe5dbcb6480392e8c7b84cbdeecc32a5c29d571.zip
games-roguelike/wrogue: [QA] Pass CC to build system
Closes: https://bugs.gentoo.org/724728 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild')
-rw-r--r--games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild b/games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild
index 074880df4a8e..db050bca72dd 100644
--- a/games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild
+++ b/games-roguelike/wrogue/wrogue-0.8.0b-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="Gothic science fantasy roguelike game"
HOMEPAGE="https://freecode.com/projects/wrogue"
@@ -11,34 +12,27 @@ SRC_URI="mirror://gentoo/${P}.zip"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="media-libs/libsdl[video]"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
PATCHES=(
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-string-allocation.patch
)
-src_prepare() {
- default
-
- sed -i \
- -e "/AppData\[0\]/ s:AppData.*:strcpy(AppData, \"/usr/share/${PN}/\");:" \
- src/lib/appdir.c \
- || die "sed failed"
+src_configure() {
+ tc-export CC
}
src_compile() {
- local myCPPFLAGS="-std=c99 -Iinclude -Ilib -Iui -Igenerate"
- local myCFLAGS="$(sdl-config --cflags) ${CFLAGS}"
- emake -C src -f linux.mak STRIP_BINARY=NO \
- CFLAGS="${myCPPFLAGS} ${myCFLAGS}" release
+ emake -C src -f linux.mak release
}
src_install() {
dobin ${PN}
+
insinto /usr/share/${PN}
doins -r data
dodoc changes.txt