summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:09 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:09 +0200
commit217931310b7294ef26594cd205ccd98a7d22ddbf (patch)
treeb07346dbcfb445dcf28f1011fc31b65d99416a32 /games-simulation
parentdev-libs/starpu: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-217931310b7294ef26594cd205ccd98a7d22ddbf.tar.gz
gentoo-217931310b7294ef26594cd205ccd98a7d22ddbf.tar.bz2
gentoo-217931310b7294ef26594cd205ccd98a7d22ddbf.zip
games-simulation/flightgear: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/flightgear/flightgear-2020.3.12.ebuild12
-rw-r--r--games-simulation/flightgear/flightgear-2020.3.13.ebuild10
-rw-r--r--games-simulation/flightgear/flightgear-9999.ebuild12
3 files changed, 23 insertions, 11 deletions
diff --git a/games-simulation/flightgear/flightgear-2020.3.12.ebuild b/games-simulation/flightgear/flightgear-2020.3.12.ebuild
index baafbbda8846..749751eb1080 100644
--- a/games-simulation/flightgear/flightgear-2020.3.12.ebuild
+++ b/games-simulation/flightgear/flightgear-2020.3.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -52,8 +52,7 @@ COMMON_DEPEND="
"
# libXi and libXmu are build-only-deps according to FindGLUT.cmake
DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.44
- qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )
+ dev-libs/boost
utils? (
x11-libs/libXi
x11-libs/libXmu
@@ -62,6 +61,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
+BDEPEND="qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )"
PATCHES=(
"${FILESDIR}/${PN}-2020.3.8-cmake.patch"
@@ -70,7 +70,11 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {
diff --git a/games-simulation/flightgear/flightgear-2020.3.13.ebuild b/games-simulation/flightgear/flightgear-2020.3.13.ebuild
index a71789169d16..49a222d30548 100644
--- a/games-simulation/flightgear/flightgear-2020.3.13.ebuild
+++ b/games-simulation/flightgear/flightgear-2020.3.13.ebuild
@@ -52,8 +52,7 @@ COMMON_DEPEND="
"
# libXi and libXmu are build-only-deps according to FindGLUT.cmake
DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.44
- qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )
+ dev-libs/boost
utils? (
x11-libs/libXi
x11-libs/libXmu
@@ -62,6 +61,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
+BDEPEND="qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )"
PATCHES=(
"${FILESDIR}/${PN}-2020.3.8-cmake.patch"
@@ -70,7 +70,11 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {
diff --git a/games-simulation/flightgear/flightgear-9999.ebuild b/games-simulation/flightgear/flightgear-9999.ebuild
index f48409f1c9d4..19115fd74b49 100644
--- a/games-simulation/flightgear/flightgear-9999.ebuild
+++ b/games-simulation/flightgear/flightgear-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -54,8 +54,7 @@ COMMON_DEPEND="
"
# libXi and libXmu are build-only-deps according to FindGLUT.cmake
DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.44
- qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )
+ dev-libs/boost
utils? (
x11-libs/libXi
x11-libs/libXmu
@@ -64,6 +63,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
+BDEPEND="qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )"
PATCHES=(
"${FILESDIR}/${PN}-2020.3.5-cmake.patch"
@@ -72,7 +72,11 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {