summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-08-11 08:25:11 +0100
committerMatthew Smith <matthew@gentoo.org>2023-08-11 08:25:47 +0100
commitc3a5342d7059213272a73a10e44c9394ca8e9058 (patch)
treeb6c7a59381e0432e4d14e45243a5308b7a17e549 /games-util
parentgames-util/grfcodec: add 6.0.6_p20230811 (diff)
downloadgentoo-c3a5342d7059213272a73a10e44c9394ca8e9058.tar.gz
gentoo-c3a5342d7059213272a73a10e44c9394ca8e9058.tar.bz2
gentoo-c3a5342d7059213272a73a10e44c9394ca8e9058.zip
games-util/nml: add 0.7.4
Also set DISTUTILS_EXT=1 and fix tests. Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/Manifest1
-rw-r--r--games-util/nml/nml-0.7.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-util/nml/Manifest b/games-util/nml/Manifest
index 2ce391bc2b72..b04958c21fa5 100644
--- a/games-util/nml/Manifest
+++ b/games-util/nml/Manifest
@@ -1 +1,2 @@
DIST nml-0.7.1.tar.gz 562101 BLAKE2B 3c29bde63048ea276d868df8aa3e13c4f1d3949c1e2c4a973e6f5f5bff7a6e57ce5c56d6605f44d91602209967cbe732f7f9031b471de3104d6c04a41582541f SHA512 a123680f89243f29ad88f2c0bc50fe7c801bd70d7cd49d71d3e5d199b1f4042e4143b71340aea3c47d938f838647016cebc0b56e39ede627497139755c9b829e
+DIST nml-0.7.4.tar.gz 569348 BLAKE2B 620f6100627d7c1cd67bbf481c96abb8be4574e0ec70cf529502980c9d8aca3660f1469fbdce99d5736d21287053b6c199a5a390f56f3704d7ceb16e6ba6582e SHA512 78a0961db3a56684fbc999f69bc5e02b9f002ba7b7a2afd39c7d4c9695b3306339ee55c4b9d711d85ca7c4c0e4d53abc71c9e0720904d44a0c388a793a28fc4b
diff --git a/games-util/nml/nml-0.7.4.ebuild b/games-util/nml/nml-0.7.4.ebuild
new file mode 100644
index 000000000000..103717df9f3b
--- /dev/null
+++ b/games-util/nml/nml-0.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into GRF/NFO files"
+HOMEPAGE="https://github.com/OpenTTD/nml/"
+SRC_URI="https://github.com/OpenTTD/nml/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP},zlib]
+ dev-python/ply[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+}
+
+python_test() {
+ # the tests involving sprites seem to fail when running in the ebuild,
+ # unless --no-cache is passed.
+ emake regression NML_FLAGS='-s -c --verbosity=1 --no-cache'
+}
+
+src_install() {
+ local DOCS=( README.md docs/changelog.txt )
+ distutils-r1_src_install
+
+ doman docs/nmlc.1
+}