summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-28 00:58:45 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-28 16:49:16 +0300
commit26600f65c83701f8319ae9270a8550a9e042834c (patch)
treef5f4f04f37487bf148e9c4ba11efc7c75b417aea /gnome-extra/gnome-shell-extensions
parentgnome-base/gnome-shell: bump to 3.26.2, support elogind, many tweaks (diff)
downloadgentoo-26600f65c83701f8319ae9270a8550a9e042834c.tar.gz
gentoo-26600f65c83701f8319ae9270a8550a9e042834c.tar.bz2
gentoo-26600f65c83701f8319ae9270a8550a9e042834c.zip
gnome-extra/gnome-shell-extensions: bump to 3.26.2
Also includes some bug fixes and translation updates from upstream unreleased 3.26 branch Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'gnome-extra/gnome-shell-extensions')
-rw-r--r--gnome-extra/gnome-shell-extensions/Manifest2
-rw-r--r--gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2-r1.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions/Manifest b/gnome-extra/gnome-shell-extensions/Manifest
index ae8afda1c1c6..30e2aa7d8fe2 100644
--- a/gnome-extra/gnome-shell-extensions/Manifest
+++ b/gnome-extra/gnome-shell-extensions/Manifest
@@ -1 +1,3 @@
DIST gnome-shell-extensions-3.24.3.tar.xz 346420 BLAKE2B 3b6f6686656ca6f395bd69fea905c4f28264db81ac0f207bc2e0d6c82410328be2bc4c98faa659d9ac551cabb73e0576c4e28def9c14e5c7710a9785528909db SHA512 7948a9cb6f5cb8d760bc42ea2865823ee60bd164b491d944edb0413e362f38ed90d39ead44ac57872a83c43c4050f5448936e739626b89a2b486a22f41d61e20
+DIST gnome-shell-extensions-3.26.2-patchset.tar.xz 14284 BLAKE2B 36a81073e1983236835eccc5dc31fb9ce23c788b2e6e69661ea70d152ea951c4763572ee3f3fc052b72c3d0be7ceb4b3a397a46ed1d4b19acaee11a72203b399 SHA512 24b83766561b12a31cd83db361fc85cd86b4c80ad92244d2669d78b44433683402ea06446b003fa65137672b052699281eca089e38eb441b8805408369232121
+DIST gnome-shell-extensions-3.26.2.tar.xz 348720 BLAKE2B c276b95c7c80d732257396b3b04e273394adb5580709db3ba6ba5129ed9f6458cf2b2daee253fb2759169417364d4392e5734b5df3bdfd00266439c2bca2db9e SHA512 8eb417a947545832d180cf7e53e1c239aec3ba1c819375071f7f036617de4ccdea5f23e81349d53dbc3c5f12334b1f1f590def7b75130e1057c314db557166e6
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2-r1.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2-r1.ebuild
new file mode 100644
index 000000000000..4d6478b6b512
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=gnome-base/libgtop-2.28.3[introspection]
+ >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/gjs-1.29
+ dev-libs/gobject-introspection:=
+ dev-libs/atk[introspection]
+ gnome-base/gnome-menus:3[introspection]
+ >=gnome-base/gnome-shell-3.14.2
+ media-libs/clutter:1.0[introspection]
+ net-libs/telepathy-glib[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme
+ x11-wm/mutter[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+# eautoreconf needs gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweak-tool GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+PATCHES=(
+ # Bug fixes and wayland compat to auto-move-windows, places-menu and window-list
+ # extensions from upstream gnome-3-26 branch, plus translation updates from there
+ "${WORKDIR}"/patches/
+)
+
+src_configure() {
+ gnome2_src_configure --enable-extensions=all
+}
+
+src_install() {
+ gnome2_src_install
+
+ local example="example@gnome-shell-extensions.gcampax.github.com"
+ if use examples; then
+ mv "${ED}usr/share/gnome-shell/extensions/${example}" \
+ "${ED}usr/share/doc/${PF}/" || die
+ else
+ rm -r "${ED}usr/share/gnome-shell/extensions/${example}" || die
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+
+ readme.gentoo_print_elog
+}