summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-12-29 01:55:12 -0500
committerSam James <sam@gentoo.org>2022-01-21 17:15:12 +0000
commitec2abdda3f803de81d92646be6b8d535db456efb (patch)
treeaf07b73ff01fe691171ee92affa096b047aefe54 /gnome-extra
parentgnome-extra/cinnamon-screensaver: 5.2.0 version bump (diff)
downloadgentoo-ec2abdda3f803de81d92646be6b8d535db456efb.tar.gz
gentoo-ec2abdda3f803de81d92646be6b8d535db456efb.tar.bz2
gentoo-ec2abdda3f803de81d92646be6b8d535db456efb.zip
gnome-extra/nemo: 5.2.3 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nemo/Manifest1
-rw-r--r--gnome-extra/nemo/nemo-5.2.3.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/gnome-extra/nemo/Manifest b/gnome-extra/nemo/Manifest
index de88e15495c7..42ce95d91272 100644
--- a/gnome-extra/nemo/Manifest
+++ b/gnome-extra/nemo/Manifest
@@ -1 +1,2 @@
DIST nemo-5.0.4.tar.gz 1487156 BLAKE2B 4ecafb315673c0939dfb2585e97957ee9d76e9621fbbece2b93d9ed10b24ec86d2c49cdd8d18ac7c8607184752fe2541508a1b626fdce763fdc8ac1b6e713e49 SHA512 e03558d336785d77c1a57d2d100906263d2015330a00d54e2cc0161d9d822740ef5c314062f90a877cee5b031b4b5caf9ebf59f22fb5e15f2e91c75bb239e488
+DIST nemo-5.2.3.tar.gz 1491685 BLAKE2B 55687410d9b1029accdcb446c3406a1a8c9e32aa9ccfcce2096a9afe14d0634729c180e5221ae193593f34518aece90c08e679b510394d27d36fb4defd80802b SHA512 141bf578a6df060f8ceb5778e271b7c474531d96562a148f200149bc77c92bdac409eb75684287c3d98b0ec088798dca292dca85c53c0c794a28c2949b82993b
diff --git a/gnome-extra/nemo/nemo-5.2.3.ebuild b/gnome-extra/nemo/nemo-5.2.3.ebuild
new file mode 100644
index 000000000000..47194cd5ea22
--- /dev/null
+++ b/gnome-extra/nemo/nemo-5.2.3.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit meson gnome2-utils python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/nemo"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc exif +nls selinux test tracker xmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# https://github.com/linuxmint/nemo/issues/2501
+RESTRICT="test"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.45.7:2[dbus]
+ >=dev-libs/gobject-introspection-0.9.12:=
+ >=dev-libs/libxml2-2.7.8:2
+ gnome-base/dconf:0=
+ >=gnome-extra/cinnamon-desktop-5.2:0=
+ gnome-extra/libgsf
+ >=x11-libs/gtk+-3.10.0:3[introspection]
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ >=x11-libs/pango-1.40.0
+ >=x11-libs/xapp-2.2.8
+
+ exif? ( >=media-libs/libexif-0.6.20:= )
+ selinux? ( sys-libs/libselinux )
+ tracker? ( >=app-misc/tracker-2.0:0= )
+ xmp? ( >=media-libs/exempi-2.2.0:= )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-themes/adwaita-icon-theme
+
+ nls? ( >=gnome-extra/cinnamon-translations-5.2 )
+"
+PDEPEND="
+ >=gnome-base/gvfs-0.1.2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.31.0
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ # Undo the switch to untex as it's not packaged.
+ "${FILESDIR}/${PN}-5.0.3-use-detex.patch"
+)
+
+DISABLE_AUTOFORMATTING="yes"
+FORCE_PRINT_ELOG="yes"
+DOC_CONTENTS="
+${PN} functionality can be extended by installing other packages.
+
+sys-apps/gnome-disk-utility - Mount archive files
+gnome-extra/nemo-fileroller - Extract/Create archive files
+
+${PN} search capabilities can be extended through external
+helpers. Install any of the following packages to make
+their associated file types searchable.
+
+Image metadata - media-gfx/exif
+MP3 tags - media-sound/id3
+Microsoft Office .doc - app-text/catdoc
+Microsoft Office .xls - dev-python/xlrd
+OpenDocument/LibreOffice - app-text/odt2txt or app-office/unoconv
+PDF - app-text/poppler[utils]
+PostScript - app-text/ghostscript-gpl
+TeX - app-text/texlive-core
+"
+
+src_prepare() {
+ default
+ python_fix_shebang files/usr/share/nemo/actions install-scripts
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif)
+ $(meson_use tracker)
+ $(meson_use xmp)
+ $(meson_use selinux)
+ $(meson_use doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}