summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-10 21:40:45 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-10 21:50:34 +0100
commit091ceaaa1be63d498cff9f287f1f60028aeba22e (patch)
treefac69d49fc06823124b35ec443b1fec5ca608797 /gnustep-base
parentnet-im/zoom: Extract official icon from the binary. (diff)
downloadgentoo-091ceaaa1be63d498cff9f287f1f60028aeba22e.tar.gz
gentoo-091ceaaa1be63d498cff9f287f1f60028aeba22e.tar.bz2
gentoo-091ceaaa1be63d498cff9f287f1f60028aeba22e.zip
gnustep-base/gnustep-base: fix compilation with dev-libs/icu-68
Bug: https://bugs.gentoo.org/759202 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/files/gnustep-base-1.27.0-icu68.patch31
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild5
2 files changed, 35 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-base/files/gnustep-base-1.27.0-icu68.patch b/gnustep-base/gnustep-base/files/gnustep-base-1.27.0-icu68.patch
new file mode 100644
index 000000000000..2374d8e24976
--- /dev/null
+++ b/gnustep-base/gnustep-base/files/gnustep-base-1.27.0-icu68.patch
@@ -0,0 +1,31 @@
+From 06fa7792a51cb970e5d010a393cb88eb127830d7 Mon Sep 17 00:00:00 2001
+From: Frederik Seiffert <frederik@algoriddim.com>
+Date: Thu, 12 Nov 2020 17:18:09 +0100
+Subject: [PATCH] Fix compilation with ICU 68.
+
+---
+ Source/GSICUString.h | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/Source/GSICUString.h b/Source/GSICUString.h
+index a82447a51..15c21491d 100644
+--- a/Source/GSICUString.h
++++ b/Source/GSICUString.h
+@@ -2,6 +2,17 @@
+ #import <Foundation/NSException.h>
+ #include <unicode/utext.h>
+
++/*
++ * Define TRUE/FALSE to be used with UBool parameters, as these are no longer
++ * defined in ICU as of ICU 68.
++ */
++#ifndef TRUE
++#define TRUE 1
++#endif
++#ifndef FALSE
++#define FALSE 0
++#endif
++
+ /**
+ * Initialises a UText structure with an NSString. If txt is NULL, then this
+ * allocates a new structure on the heap, otherwise it fills in the existing
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild
index 5c08a364b2a7..00a2ef6a004f 100644
--- a/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild
+++ b/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild
@@ -28,7 +28,10 @@ RDEPEND="${GNUSTEP_CORE_DEPEND}
DEPEND="${RDEPEND}
virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${PN}-1.26.0-no_compress_man.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.0-no_compress_man.patch
+ "${FILESDIR}"/${P}-icu68.patch
+)
src_configure() {
egnustep_env