summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-19 19:55:08 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:48:51 +0200
commit1073621489e63137be274e6320352b5fa8c6710c (patch)
tree6620779231b5a063a34e8cdc0f776454882a0937 /gnustep-libs
parentgnustep-base/gnustep-back-art: EAPI8 bump, fix LICENSE (diff)
downloadgentoo-1073621489e63137be274e6320352b5fa8c6710c.tar.gz
gentoo-1073621489e63137be274e6320352b5fa8c6710c.tar.bz2
gentoo-1073621489e63137be274e6320352b5fa8c6710c.zip
gnustep-libs/dbuskit: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..841a257ae165
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools gnustep-2
+
+DESCRIPTION="Framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="https://github.com/gnustep/libs-dbuskit"
+SRC_URI="https://github.com/gnustep/libs-dbuskit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libs-${P}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-remove_gc.patch )
+
+src_prepare() {
+ default
+
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+
+ eautoreconf
+}