summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-13 22:41:45 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-13 22:48:25 -0400
commitc4363db0eea0842387815bb6b8f55e846b999585 (patch)
tree316aa366386b9fa09a56350283cf23b1ef185e9d /gui-libs
parentgames-arcade/cdogs-sdl: add 1.3.1 (diff)
downloadgentoo-c4363db0eea0842387815bb6b8f55e846b999585.tar.gz
gentoo-c4363db0eea0842387815bb6b8f55e846b999585.tar.bz2
gentoo-c4363db0eea0842387815bb6b8f55e846b999585.zip
gui-libs/gtksourceview: Version bump to 5.4.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtksourceview/Manifest1
-rw-r--r--gui-libs/gtksourceview/gtksourceview-5.4.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-libs/gtksourceview/Manifest b/gui-libs/gtksourceview/Manifest
index 03964e1c0cd5..1b658cd0e8e5 100644
--- a/gui-libs/gtksourceview/Manifest
+++ b/gui-libs/gtksourceview/Manifest
@@ -1 +1,2 @@
DIST gtksourceview-5.4.1.tar.xz 1258668 BLAKE2B 588dc30093f9300c96aabdabd5bccc84a4fe93ebdcfab61f72a33113ec3f53826022d730a79e7b467a392d4467a0370b2fd3e6edf5cb2f31525b7c3d18e52107 SHA512 5270db969455ad29498a02a851802228575c9b4b6cf6d4f9736bff95f869f1052550034fe6cc4f0c8d29174559d147068dcd088ab09b2008399f7a717aced298
+DIST gtksourceview-5.4.2.tar.xz 1261496 BLAKE2B 3c7447de6d252c7fbccd5fb18222aeb25cd264b53847d3fb45a5b30a528d3a850d059f226a696e9d8462085910c67e318be10de89c0e7a554787fb25f27a6674 SHA512 eef5267bd473327f4e3e7b79d4a96c53067e221e9f171dde864a7866ccab8258ca9e13b5f59e40272fd7e3acd9e1e08bb4bea3674fa2864ec108b4a47220e9d3
diff --git a/gui-libs/gtksourceview/gtksourceview-5.4.2.ebuild b/gui-libs/gtksourceview/gtksourceview-5.4.2.ebuild
new file mode 100644
index 000000000000..57c8b2dbb0cb
--- /dev/null
+++ b/gui-libs/gtksourceview/gtksourceview-5.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx xdg
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+
+IUSE="gtk-doc +introspection sysprof +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.70:2
+ >=gui-libs/gtk-4.5:4[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ introspection? ( >=dev-libs/gobject-introspection-1.70.0:= )
+ >=dev-libs/fribidi-0.19.7
+ media-libs/fontconfig
+ x11-libs/pango[introspection?]
+ >=dev-libs/libpcre2-10.21:=[-recursion-limit(-)]
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dinstall_tests=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use sysprof)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Tests fail in test-regex with libpcre2[recursion-limit] - https://gitlab.gnome.org/GNOME/gtksourceview/-/issues/255
+ # Ensured OK via USE dep, as it would mean issues in real usage for syntax highlighting as well
+ virtx meson_src_test --timeout-multiplier=2
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/${PN}-5/language-specs
+ newins "${FILESDIR}"/5-gentoo.lang gentoo.lang
+
+ if use gtk-doc ; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}