summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /java-virtuals/servlet-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'java-virtuals/servlet-api')
-rw-r--r--java-virtuals/servlet-api/metadata.xml9
-rw-r--r--java-virtuals/servlet-api/servlet-api-2.2.ebuild21
-rw-r--r--java-virtuals/servlet-api/servlet-api-2.3.ebuild21
-rw-r--r--java-virtuals/servlet-api/servlet-api-2.4.ebuild24
-rw-r--r--java-virtuals/servlet-api/servlet-api-2.5-r1.ebuild24
-rw-r--r--java-virtuals/servlet-api/servlet-api-3.0-r1.ebuild23
6 files changed, 122 insertions, 0 deletions
diff --git a/java-virtuals/servlet-api/metadata.xml b/java-virtuals/servlet-api/metadata.xml
new file mode 100644
index 000000000000..4989a7a7a7eb
--- /dev/null
+++ b/java-virtuals/servlet-api/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ Virtual of Servlet API to allow for user selectable implementation of
+ the Servlet API specification.
+ </longdescription>
+</pkgmetadata>
diff --git a/java-virtuals/servlet-api/servlet-api-2.2.ebuild b/java-virtuals/servlet-api/servlet-api-2.2.ebuild
new file mode 100644
index 000000000000..a820191a9d7a
--- /dev/null
+++ b/java-virtuals/servlet-api/servlet-api-2.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-virtuals-2
+
+DESCRIPTION="Virtual for servlet api"
+HOMEPAGE="http://java.sun.com/products/servlet/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-java/tomcat-servlet-api:${SLOT}"
+DEPEND=""
+
+JAVA_VIRTUAL_PROVIDES="tomcat-servlet-api-${SLOT}"
diff --git a/java-virtuals/servlet-api/servlet-api-2.3.ebuild b/java-virtuals/servlet-api/servlet-api-2.3.ebuild
new file mode 100644
index 000000000000..e3cd41325c1e
--- /dev/null
+++ b/java-virtuals/servlet-api/servlet-api-2.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-virtuals-2
+
+DESCRIPTION="Virtual for servlet api"
+HOMEPAGE="http://java.sun.com/products/servlet/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS=" amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-java/tomcat-servlet-api:${SLOT}"
+DEPEND=""
+
+JAVA_VIRTUAL_PROVIDES="tomcat-servlet-api-${SLOT}"
diff --git a/java-virtuals/servlet-api/servlet-api-2.4.ebuild b/java-virtuals/servlet-api/servlet-api-2.4.ebuild
new file mode 100644
index 000000000000..7ed78d0340f8
--- /dev/null
+++ b/java-virtuals/servlet-api/servlet-api-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-virtuals-2
+
+DESCRIPTION="Virtual for servlet api"
+HOMEPAGE="http://java.sun.com/products/servlet/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="|| (
+ dev-java/tomcat-servlet-api:${SLOT}
+ dev-java/resin-servlet-api:${SLOT}
+ )"
+DEPEND=""
+
+JAVA_VIRTUAL_PROVIDES="tomcat-servlet-api-${SLOT} resin-servlet-api-${SLOT}"
diff --git a/java-virtuals/servlet-api/servlet-api-2.5-r1.ebuild b/java-virtuals/servlet-api/servlet-api-2.5-r1.ebuild
new file mode 100644
index 000000000000..771212b934da
--- /dev/null
+++ b/java-virtuals/servlet-api/servlet-api-2.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit java-virtuals-2
+
+DESCRIPTION="Virtual for servlet api"
+HOMEPAGE="http://java.sun.com/products/servlet/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="|| (
+ dev-java/tomcat-servlet-api:${SLOT}
+ dev-java/resin-servlet-api:${SLOT}
+ dev-java/glassfish-servlet-api:${SLOT}
+ )"
+
+JAVA_VIRTUAL_PROVIDES="tomcat-servlet-api-${SLOT} resin-servlet-api-${SLOT} glassfish-servlet-api-${SLOT}"
diff --git a/java-virtuals/servlet-api/servlet-api-3.0-r1.ebuild b/java-virtuals/servlet-api/servlet-api-3.0-r1.ebuild
new file mode 100644
index 000000000000..3a0109cea110
--- /dev/null
+++ b/java-virtuals/servlet-api/servlet-api-3.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit java-virtuals-2
+
+DESCRIPTION="Virtual for servlet api"
+HOMEPAGE="http://java.sun.com/products/servlet/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS=" amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| (
+ dev-java/tomcat-servlet-api:${SLOT}
+ dev-java/resin-servlet-api:${SLOT}
+ )"
+
+JAVA_VIRTUAL_PROVIDES="tomcat-servlet-api-${SLOT} resin-servlet-api-${SLOT}"