summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/dolphin-plugins
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/dolphin-plugins')
-rw-r--r--kde-apps/dolphin-plugins/Manifest1
-rw-r--r--kde-apps/dolphin-plugins/dolphin-plugins-18.08.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins/Manifest b/kde-apps/dolphin-plugins/Manifest
index 2bd2cd1c8e3f..fa5abc85d0da 100644
--- a/kde-apps/dolphin-plugins/Manifest
+++ b/kde-apps/dolphin-plugins/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-18.04.3.tar.xz 191408 BLAKE2B e27bd189d02f922e55fb216bfb80032bf611ec109a3c3f9e3b2cd2466f831e59d548c2d2861a784972e7dcc676e1e7baf28f9a44e8ce7cf1569846da4d6cb86a SHA512 641562f44750bad8ca431be470cf691ea72647ac2b6c5bef7ff83d1d538bc13b7f8d082589c0d2c8c208c14a6007e412f4be8a8e733ebde7132dca6d5724798e
+DIST dolphin-plugins-18.08.1.tar.xz 193248 BLAKE2B ea2d4c9b4bcd2eb36e0bc7515d8f2e98ed8f79fb80fdca6e7088e9974c841f41bc7aba1b38066e2261be4a73a1cfd11cee3bd1dac437c45c088cca73b8dd44ef SHA512 44bf6051e3aa54950e52fcfc65a2ea9b9a110e4dcb773f24b09c6206dec30c0bd6aeea3e463e5cde15d8f86e1803d25fdf1db4b3c6173a35b829ed74d37206fc
diff --git a/kde-apps/dolphin-plugins/dolphin-plugins-18.08.1.ebuild b/kde-apps/dolphin-plugins/dolphin-plugins-18.08.1.ebuild
new file mode 100644
index 000000000000..13dab37812c5
--- /dev/null
+++ b/kde-apps/dolphin-plugins/dolphin-plugins-18.08.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="false"
+inherit kde5
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~x86"
+IUSE="bazaar dropbox git mercurial subversion"
+
+# FIXME: required in root CMakeLists.txt, but:
+# kdelibs4support only required by git?
+# kxmlgui, qtnetwork only required by dropbox?
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ git? (
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep ktextwidgets)
+ )
+ mercurial? (
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ dropbox? ( net-misc/dropbox-cli )
+ git? ( dev-vcs/git )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_bazaar=$(usex bazaar)
+ -DBUILD_dropbox=$(usex dropbox)
+ -DBUILD_git=$(usex git)
+ -DBUILD_hg=$(usex mercurial)
+ -DBUILD_svn=$(usex subversion)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ { use bazaar || use dropbox || use git || use subversion || use mercurial; } && kde5_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use dropbox && ! use git && ! use subversion && ! use mercurial; then
+ elog "You have disabled all plugin use flags. If you want to have vcs"
+ elog "integration in dolphin, enable those of your needs."
+ fi
+}