summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-01-04 18:58:44 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-01-05 05:12:14 +1100
commit20f1b82d255b934f7dbf23b01c501b874110384e (patch)
treee0afd65bd8cb77d5c506310801e85f6bdaea8aa2 /kde-apps/dolphin
parentkde-apps/konsolepart: Add it as alternative dependency to konsole:4 (diff)
downloadgentoo-20f1b82d255b934f7dbf23b01c501b874110384e.tar.gz
gentoo-20f1b82d255b934f7dbf23b01c501b874110384e.tar.bz2
gentoo-20f1b82d255b934f7dbf23b01c501b874110384e.zip
kde-apps/dolphin: Add RDEPEND on kde-apps/konsolepart
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/dolphin-4.14.3-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/dolphin/dolphin-4.14.3-r1.ebuild b/kde-apps/dolphin/dolphin-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..ae6d9f7cb132
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-4.14.3-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kactivities '' 4.13)
+ $(add_kdeapps_dep libkonq)
+ media-libs/phonon[qt4]
+ x11-libs/libXrender
+ semantic-desktop? (
+ $(add_kdebase_dep baloo)
+ $(add_kdeapps_dep baloo-widgets)
+ $(add_kdebase_dep kfilemetadata)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kdebase-kioslaves)
+ $(add_kdeapps_dep kfind)
+ $(add_kdeapps_dep konsolepart)
+ thumbnail? (
+ $(add_kdeapps_dep thumbnailers)
+ || (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep mplayerthumbs)
+ )
+ )
+"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Baloo)
+ $(cmake-utils_use_with semantic-desktop BalooWidgets)
+ $(cmake-utils_use_with semantic-desktop KFileMetaData)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version media-gfx/icoutils ; then
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ fi
+}