summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 09:09:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 12:53:59 +0200
commit9692e22a1abb6e54738747ed8617439cfc78f71e (patch)
tree9526582a3145bb4f3188b05a6e48699fe745b522 /kde-apps/konsole
parentkde-apps/khelpcenter: drop 22.04.2* (diff)
downloadgentoo-9692e22a1abb6e54738747ed8617439cfc78f71e.tar.gz
gentoo-9692e22a1abb6e54738747ed8617439cfc78f71e.tar.bz2
gentoo-9692e22a1abb6e54738747ed8617439cfc78f71e.zip
kde-apps/konsole: drop 22.04.2*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsole')
-rw-r--r--kde-apps/konsole/Manifest1
-rw-r--r--kde-apps/konsole/files/konsole-22.04.2-musl_malloc_trim.patch92
-rw-r--r--kde-apps/konsole/konsole-22.04.2.ebuild70
3 files changed, 0 insertions, 163 deletions
diff --git a/kde-apps/konsole/Manifest b/kde-apps/konsole/Manifest
index 3fca926afbdd..9af0f91518f4 100644
--- a/kde-apps/konsole/Manifest
+++ b/kde-apps/konsole/Manifest
@@ -1,3 +1,2 @@
DIST konsole-21.12.3.tar.xz 1391132 BLAKE2B d59bac520ab2fc6bd5edb8e3ea64f8bd7434ece2a1718a8149c7aed03321f91423903ce1a2a1b3ee604b8b2425dcee6df32f26f57003251e33fb1bfbc7cc1faf SHA512 75e1ad0c35b56e7e0e903600d87ba2391efe8f5715917d5cb5d13be27f1a5c2d971817e0acfbc291670c2076f2c829c80cf657641994aacfd71399846adb75e0
-DIST konsole-22.04.2.tar.xz 1467412 BLAKE2B 32c76d3ec6405887f2a9d3bb0234b3658b344fb27936d379c0638e1952960b4cff4503d19ad69ec272c713897016a4ef47f5f6fe1d5f8a730965e91678596098 SHA512 cd8ecc3e494cc2c087e03b4537b822986d36a04d75edf9c8d053a79578e148498582238f96018262cc74cdf86fe7abf7a0a4408e220ec0a9a49bb94d8aa10a76
DIST konsole-22.04.3.tar.xz 1476120 BLAKE2B 6675955b6c2257d342e7560c759c95fe19301f76c72db6c542275acc879b78606eeb17893111930d575290048cb9047c7b42b8af7b60169d6995ae0efd03fd35 SHA512 05728efc051ae76b395c7ece1599e654ce3bdae0c8b43d7f8e34c76f57041f7722e161147c4a5699377b764aa8b3799421d5c735967216c5420b6f92330c1338
diff --git a/kde-apps/konsole/files/konsole-22.04.2-musl_malloc_trim.patch b/kde-apps/konsole/files/konsole-22.04.2-musl_malloc_trim.patch
deleted file mode 100644
index 455dbc55821f..000000000000
--- a/kde-apps/konsole/files/konsole-22.04.2-musl_malloc_trim.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-https://invent.kde.org/utilities/konsole/-/merge_requests/621
-https://invent.kde.org/utilities/konsole/-/commit/b8c90a830ceaf293e61f6cd5217bb3e584f997b8 (backport)
-
-
-From b8c90a830ceaf293e61f6cd5217bb3e584f997b8 Mon Sep 17 00:00:00 2001
-From: Heiko Becker <heiko.becker@kde.org>
-Date: Tue, 22 Mar 2022 22:08:10 +0100
-Subject: [PATCH] Detect the presence of malloc_trim to fix the build with musl
-
-malloc_trim is indeed a GNU extension, but an extension of glibc.
-Relying on __GNUC__ unfortunately doesn't help with that. Check for
-the actual presence of malloc_trim with cmake's check_function_exists
-instead.
-This fixes the build with musl libc, which doesn't come with
-malloc_trim.
-
-Co-authored-by: Ahmad Samir <a.samirh78@gmail.com>
-(cherry picked from commit f6310c2b791275f3727f2240ca7fab9f58db943d)
----
- CMakeLists.txt | 2 +-
- src/Screen.cpp | 17 +++++++----------
- src/config-konsole.h.cmake | 4 ++--
- 3 files changed, 10 insertions(+), 13 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f2c9d43ac..b306597ba 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -94,7 +94,7 @@ set(HAVE_X11 ${X11_FOUND})
- # Check for function GETPWUID
- check_symbol_exists(getpwuid "pwd.h" HAVE_GETPWUID)
-
--check_include_files(malloc.h HAVE_MALLOC_H)
-+check_function_exists(malloc_trim HAVE_MALLOC_TRIM)
-
- # See above includes for defaults
- add_definitions(
-diff --git a/src/Screen.cpp b/src/Screen.cpp
-index e57314cd5..dff9b54a4 100644
---- a/src/Screen.cpp
-+++ b/src/Screen.cpp
-@@ -28,13 +28,11 @@
- #include "history/HistoryType.h"
- #include "profile/Profile.h"
-
--#ifdef HAVE_MALLOC_H
-- // For malloc_trim, which is a GNU extension
-- #ifdef __GNUC__
-- extern "C" {
-- #include <malloc.h>
-- }
-- #endif
-+#ifdef HAVE_MALLOC_TRIM
-+// For malloc_trim, which is a GNU extension
-+extern "C" {
-+#include <malloc.h>
-+}
- #endif
-
- using namespace Konsole;
-@@ -1799,14 +1797,13 @@ void Screen::setScroll(const HistoryType &t, bool copyPreviousScroll)
- t.scroll(_history);
- }
-
--#ifdef HAVE_MALLOC_H
-+#ifdef HAVE_MALLOC_TRIM
-+
- #ifdef Q_OS_LINUX
--#ifdef __GNUC__
- // We might have been using gigabytes of memory, so make sure it is actually released
- malloc_trim(0);
- #endif
- #endif
--#endif
- }
-
- bool Screen::hasScroll() const
-diff --git a/src/config-konsole.h.cmake b/src/config-konsole.h.cmake
-index b74992b0a..4b1d9b515 100644
---- a/src/config-konsole.h.cmake
-+++ b/src/config-konsole.h.cmake
-@@ -15,5 +15,5 @@
-
- #cmakedefine HAVE_GETPWUID ${HAVE_GETPWUID}
-
--/* Define to 1 if you have the <malloc.h> header file. */
--#cmakedefine HAVE_MALLOC_H 1
-+/* Defined if system has the malloc_trim function, which is a GNU extension */
-+#cmakedefine HAVE_MALLOC_TRIM
---
-GitLab
-
diff --git a/kde-apps/konsole/konsole-22.04.2.ebuild b/kde-apps/konsole/konsole-22.04.2.ebuild
deleted file mode 100644
index 28bfdda48455..000000000000
--- a/kde-apps/konsole/konsole-22.04.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_HANDBOOK="optional"
-ECM_TEST="true"
-KFMIN=5.92.0
-QTMIN=5.15.3
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="KDE's terminal emulator"
-HOMEPAGE="https://apps.kde.org/konsole/ https://konsole.kde.org"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="X"
-
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtprintsupport-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kguiaddons-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kpty-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- X? ( x11-libs/libX11 )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-22.04.2-musl_malloc_trim.patch )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package X X11)
- )
-
- ecm_src_configure
-}
-
-src_test() {
- # drkonqi process interferes. bug 702690
- local myctestargs=(
- -E "(DBusTest)"
- )
-
- ecm_src_test
-}