summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/krdc/krdc-18.08.1.ebuild
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/krdc/krdc-18.08.1.ebuild')
-rw-r--r--kde-apps/krdc/krdc-18.08.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/krdc/krdc-18.08.1.ebuild b/kde-apps/krdc/krdc-18.08.1.ebuild
new file mode 100644
index 000000000000..b2db820336ce
--- /dev/null
+++ b/kde-apps/krdc/krdc-18.08.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde5
+
+DESCRIPTION="Remote desktop connection (RDP and VNC) client"
+HOMEPAGE="https://www.kde.org/applications/internet/krdc/"
+KEYWORDS="~amd64 ~x86"
+IUSE="+rdp vnc"
+
+#nx? ( >=net-misc/nxcl-0.9-r1 ) disabled upstream, last checked 2016-01-24
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ vnc? ( >=net-libs/libvncserver-0.9 )
+"
+RDEPEND="${DEPEND}
+ rdp? ( >=net-misc/freerdp-1.1.0_beta1[X] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LibVNCServer=$(usex vnc)
+ )
+
+ kde5_src_configure
+}