summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/ksystemlog
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-18.12.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index 4cc0b7102fdf..82c14d8bd631 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1,2 +1,3 @@
DIST ksystemlog-18.08.3.tar.xz 1966776 BLAKE2B f6715026b009296856c9120b0236b4efff681d1cd02d7694db8dde3d8df7a521c0640540ee3b1cfd69d1cf8bf8a6976773a217dcfcacbde5f4aaeb2689786fe9 SHA512 0cdf798c3d6c51851fd3cc2eda04e445a413459ee29d7b98d799a749d21a6a80447bce37651ac22e4b652fc10452dc2fb6408108cce2a968e7fc7f2379b0c915
DIST ksystemlog-18.12.1.tar.xz 1924228 BLAKE2B c7742e1f03a0d8eb034ee2ed5b08132361d45335219a4f99eb9e6be857b68aa2794d3d213f0f6f05b3d0bcfbb1d78358aa1b0b1b46665c3086cc90d2f9244bd4 SHA512 93e5beaab4f064ad09edd24f15a6eb9f7b4a7823b7edf5af8b4b788d6677c268e2582f421ef28baad9dead1474ce6519745058da281441cc60de94725a62a03c
+DIST ksystemlog-18.12.2.tar.xz 1924272 BLAKE2B d6b4eaa49eddc597b790437da9501f0929d85c2017a956cafb674bb0f1a01912031de2b044426f56eb299818932bbe3723619627d0329ae607169a37a344585d SHA512 4eb98902462b661e5351ecd65f93c723d4d6d96215cda3de87dde26af9f8acd1086776f95466a9cace97314c781e18e62c93d31721e0a1fe5156a7ba2e52c95e
diff --git a/kde-apps/ksystemlog/ksystemlog-18.12.2.ebuild b/kde-apps/ksystemlog/ksystemlog-18.12.2.ebuild
new file mode 100644
index 000000000000..ee7886120b1e
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-18.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp || die
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" \
+ -i ksystemlog/tests/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}