summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-04 21:36:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-05 00:27:36 +0200
commit2b39e72f79cbcd3f12b0685c59cb891067f4526f (patch)
tree2072923f3514899d61bdb1872c560d852948fb93 /kde-apps/libkgapi
parentkde-apps/libkdepim: drop 22.08.3 (diff)
downloadgentoo-2b39e72f79cbcd3f12b0685c59cb891067f4526f.tar.gz
gentoo-2b39e72f79cbcd3f12b0685c59cb891067f4526f.tar.bz2
gentoo-2b39e72f79cbcd3f12b0685c59cb891067f4526f.zip
kde-apps/libkgapi: drop 22.08.3, 22.08.3-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/libkgapi')
-rw-r--r--kde-apps/libkgapi/Manifest1
-rw-r--r--kde-apps/libkgapi/files/libkgapi-22.08.3-AccountManager-dont-keep-finished-promises-in-cache.patch27
-rw-r--r--kde-apps/libkgapi/files/libkgapi-22.08.3-dont-cache-promises-for-AccountManager-findAccount.patch75
-rw-r--r--kde-apps/libkgapi/libkgapi-22.08.3-r1.ebuild49
-rw-r--r--kde-apps/libkgapi/libkgapi-22.08.3.ebuild44
5 files changed, 0 insertions, 196 deletions
diff --git a/kde-apps/libkgapi/Manifest b/kde-apps/libkgapi/Manifest
index 9ddee29318c6..bab535d470f8 100644
--- a/kde-apps/libkgapi/Manifest
+++ b/kde-apps/libkgapi/Manifest
@@ -1,2 +1 @@
-DIST libkgapi-22.08.3.tar.xz 242496 BLAKE2B e38ac44878e5425b4cb6922b13bbca4268795f92a6e50123c3c4ff228f80bec58a0146e4548aa8d5284780f5700236b5f52a96962f2ac8caa3d676847b6ab2db SHA512 b393691240954c2e6262cef32fc04dc2d2137f97256d8bc43d8ed6cb6007122819da43206fca6a5cf3e6c6201fd4b7e43bfc1972733a7b6c25221895eeb91991
DIST libkgapi-22.12.3.tar.xz 245596 BLAKE2B fca1c96dd35446fb960601971c477c110c8563ceef62c433c4a4808b3f119bb37239d4171180f00433cc42b6dc2dd2539ccde55cb5f290526a86151ad6f95b3f SHA512 551c5209bb22ea5340cb3b6c28841b1a9c6a5ca42ffbc95961c89139ad8f24152869d841360bd7d9bd56dd043a74fc4ea61bc6a3beeac49f20c7dfe464a84bf0
diff --git a/kde-apps/libkgapi/files/libkgapi-22.08.3-AccountManager-dont-keep-finished-promises-in-cache.patch b/kde-apps/libkgapi/files/libkgapi-22.08.3-AccountManager-dont-keep-finished-promises-in-cache.patch
deleted file mode 100644
index 485bc7d840f8..000000000000
--- a/kde-apps/libkgapi/files/libkgapi-22.08.3-AccountManager-dont-keep-finished-promises-in-cache.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From b5a581d98d9b57363c44bd98eeab7243fbf13a22 Mon Sep 17 00:00:00 2001
-From: Fabian Vogt <fabian@ritter-vogt.de>
-Date: Mon, 21 Nov 2022 13:00:41 +0100
-Subject: [PATCH] AccountManager: Don't keep finished promises in the cache
-
-AccountPromises are destroyed one event loop cycle after they finished().
-They won't emit finished() again, so they can't be used.
----
- src/core/accountmanager.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/accountmanager.cpp b/src/core/accountmanager.cpp
-index 42719c5e..da5c37b6 100644
---- a/src/core/accountmanager.cpp
-+++ b/src/core/accountmanager.cpp
-@@ -134,7 +134,7 @@ public:
- auto promise = mPendingPromises.value(key, nullptr);
- if (!promise) {
- promise = new AccountPromise(q);
-- QObject::connect(promise, &QObject::destroyed, q, [key, this]() {
-+ QObject::connect(promise, &AccountPromise::finished, q, [key, this]() {
- mPendingPromises.remove(key);
- });
- mPendingPromises.insert(key, promise);
---
-GitLab
-
diff --git a/kde-apps/libkgapi/files/libkgapi-22.08.3-dont-cache-promises-for-AccountManager-findAccount.patch b/kde-apps/libkgapi/files/libkgapi-22.08.3-dont-cache-promises-for-AccountManager-findAccount.patch
deleted file mode 100644
index b24b80377686..000000000000
--- a/kde-apps/libkgapi/files/libkgapi-22.08.3-dont-cache-promises-for-AccountManager-findAccount.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From d677a08c21fd99e7e8be0a0899f797f9237207e4 Mon Sep 17 00:00:00 2001
-From: Fabian Vogt <fabian@ritter-vogt.de>
-Date: Mon, 21 Nov 2022 13:02:27 +0100
-Subject: [PATCH] Don't cache promises for AccountManager::findAccount
-
-Unlike AccountManager::getAccount and AccountManager::refreshTokens, this
-method does not return an authenticated account. However, the promises are
-cached for all of them in the same store, so it was possible for a call to
-e.g. refreshTokens to get a promise created by findAccount instead, resulting
-in an unexpected result. Just don't cache promises created by findAccount.
-
-BUG: 406839
-BUG: 409122
-BUG: 421664
-BUG: 456923
----
- src/core/accountmanager.cpp | 38 ++++++++++++++++++-------------------
- 1 file changed, 18 insertions(+), 20 deletions(-)
-
-diff --git a/src/core/accountmanager.cpp b/src/core/accountmanager.cpp
-index da5c37b6..c6b8189d 100644
---- a/src/core/accountmanager.cpp
-+++ b/src/core/accountmanager.cpp
-@@ -265,30 +265,28 @@ AccountPromise *AccountManager::refreshTokens(const QString &apiKey, const QStri
-
- AccountPromise *AccountManager::findAccount(const QString &apiKey, const QString &accountName, const QList<QUrl> &scopes)
- {
-- auto promise = d->createPromise(apiKey, accountName);
-- if (!promise->d->isRunning()) {
-- QTimer::singleShot(0, this, [=]() {
-- d->ensureStore([=](bool storeOpened) {
-- if (!storeOpened) {
-- promise->d->setError(tr("Failed to open account store"));
-- return;
-- }
-+ auto promise = new AccountPromise(this);
-+ QTimer::singleShot(0, this, [=]() {
-+ d->ensureStore([=](bool storeOpened) {
-+ if (!storeOpened) {
-+ promise->d->setError(tr("Failed to open account store"));
-+ return;
-+ }
-
-- const auto account = d->mStore->getAccount(apiKey, accountName);
-- if (!account) {
-- promise->d->setAccount({});
-+ const auto account = d->mStore->getAccount(apiKey, accountName);
-+ if (!account) {
-+ promise->d->setAccount({});
-+ } else {
-+ const auto currentScopes = account->scopes();
-+ if (scopes.isEmpty() || d->compareScopes(currentScopes, scopes)) {
-+ promise->d->setAccount(account);
- } else {
-- const auto currentScopes = account->scopes();
-- if (scopes.isEmpty() || d->compareScopes(currentScopes, scopes)) {
-- promise->d->setAccount(account);
-- } else {
-- promise->d->setAccount({});
-- }
-+ promise->d->setAccount({});
- }
-- });
-+ }
- });
-- promise->d->setRunning();
-- }
-+ });
-+ promise->d->setRunning();
- return promise;
- }
-
---
-GitLab
-
diff --git a/kde-apps/libkgapi/libkgapi-22.08.3-r1.ebuild b/kde-apps/libkgapi/libkgapi-22.08.3-r1.ebuild
deleted file mode 100644
index 0ba982756bcb..000000000000
--- a/kde-apps/libkgapi/libkgapi-22.08.3-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="true"
-KFMIN=5.96.0
-QTMIN=5.15.5
-VIRTUALX_REQUIRED="test"
-inherit ecm gear.kde.org
-
-DESCRIPTION="Library for accessing Google calendar and contact resources"
-HOMEPAGE="https://api.kde.org/kdepim/libkgapi/html/index.html"
-
-LICENSE="LGPL-2.1+"
-SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv x86"
-IUSE="nls"
-
-DEPEND="
- dev-libs/cyrus-sasl:2
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/kcalendarcore-${KFMIN}:5
- >=kde-frameworks/kcontacts-${KFMIN}:5
- >=kde-frameworks/kwallet-${KFMIN}:5
-"
-RDEPEND="${DEPEND}"
-BDEPEND="nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )"
-
-PATCHES=(
- "${FILESDIR}/${P}-AccountManager-dont-keep-finished-promises-in-cache.patch"
- "${FILESDIR}/${P}-dont-cache-promises-for-AccountManager-findAccount.patch"
-)
-
-src_test() {
- local myctestargs=(
- # Both fail for multiple distros, see bug #832709 for more discussion
- # Revisit at least once Qt 5.15.3 is in wider distribution (in Gentoo at least):
- # contacts-contactcreatejobtest, contacts-contactmodifyjobtest
- # More failures not specific to Gentoo, bug #852593, KDE-bug #440648:
- # calendar-eventcreatejobtest, calendar-eventfetchjobtest, calendar-eventmodifyjobtest
- -E "(contacts-contactcreatejobtest|contacts-contactmodifyjobtest|calendar-eventcreatejobtest|calendar-eventfetchjobtest|calendar-eventmodifyjobtest)"
- )
-
- virtx cmake_src_test
-}
diff --git a/kde-apps/libkgapi/libkgapi-22.08.3.ebuild b/kde-apps/libkgapi/libkgapi-22.08.3.ebuild
deleted file mode 100644
index 88c1e40bcf0b..000000000000
--- a/kde-apps/libkgapi/libkgapi-22.08.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="true"
-KFMIN=5.96.0
-QTMIN=5.15.5
-VIRTUALX_REQUIRED="test"
-inherit ecm gear.kde.org
-
-DESCRIPTION="Library for accessing Google calendar and contact resources"
-HOMEPAGE="https://api.kde.org/kdepim/libkgapi/html/index.html"
-
-LICENSE="LGPL-2.1+"
-SLOT="5"
-KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
-IUSE="nls"
-
-DEPEND="
- dev-libs/cyrus-sasl:2
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/kcalendarcore-${KFMIN}:5
- >=kde-frameworks/kcontacts-${KFMIN}:5
- >=kde-frameworks/kwallet-${KFMIN}:5
-"
-RDEPEND="${DEPEND}"
-BDEPEND="nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )"
-
-src_test() {
- local myctestargs=(
- # Both fail for multiple distros, see bug #832709 for more discussion
- # Revisit at least once Qt 5.15.3 is in wider distribution (in Gentoo at least):
- # contacts-contactcreatejobtest, contacts-contactmodifyjobtest
- # More failures not specific to Gentoo, bug #852593, KDE-bug #440648:
- # calendar-eventcreatejobtest, calendar-eventfetchjobtest, calendar-eventmodifyjobtest
- -E "(contacts-contactcreatejobtest|contacts-contactmodifyjobtest|calendar-eventcreatejobtest|calendar-eventfetchjobtest|calendar-eventmodifyjobtest)"
- )
-
- virtx cmake_src_test
-}