summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/kdepim-common-libs/kdepim-common-libs-4.14.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/kdepim-common-libs/kdepim-common-libs-4.14.10.ebuild')
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.14.10.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.10.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.10.ebuild
new file mode 100644
index 000000000000..cd03e6a23a6a
--- /dev/null
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.10.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim"
+EGIT_BRANCH="KDE/4.14"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Common libraries for KDE PIM apps"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug google"
+
+DEPEND="
+ app-crypt/gpgme
+ >=app-office/akonadi-server-1.12.90
+ dev-libs/grantlee:0
+ $(add_kdebase_dep baloo '' 4.14.3)
+ $(add_kdebase_dep kdepimlibs 'akonadi(+)')
+ google? ( net-libs/libkgapi:4 )
+"
+RDEPEND="${DEPEND}
+ !kde-base/akonadi:4
+ !kde-base/libkdepim:4
+ !kde-base/libkleo:4
+ !kde-base/libkpgp:4
+ !<kde-base/kaddressbook-4.11.50:4
+ !kde-base/kdepim-wizards:4
+ !<kde-base/kmail-4.14.5
+ !<kde-base/korganizer-4.5.67:4
+ app-crypt/gnupg
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+RESTRICT="test"
+# bug 393131
+
+KMEXTRA="
+ agents/sendlateragent/
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ composereditor-ng/
+ grantleeeditor/grantleethemeeditor/
+ grantleetheme/
+ incidenceeditor-ng/
+ libkdepim/
+ libkdepimdbusinterfaces/
+ libkleo/
+ libkpgp/
+ kaddressbookgrantlee/
+ kdgantt2/
+ mailcommon/
+ mailimporter/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ noteshared/
+ pimcommon/
+ templateparser/
+"
+KMEXTRACTONLY="
+ agents/mailfilteragent/org.freedesktop.Akonadi.MailFilterAgent.xml
+ kleopatra/
+ kmail/
+ knode/org.kde.knode.xml
+ korgac/org.kde.korganizer.KOrgac.xml
+ korganizer/data/org.kde.korganizer.Korganizer.xml
+ korganizer/data/org.kde.Korganizer.Calendar.xml
+"
+KMSAVELIBS="true"
+
+PATCHES=(
+ "${FILESDIR}/install-composereditorng.patch"
+ "${FILESDIR}/${PN}-install-headers.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+ sed -e '/folderarchiveagent.desktop/d' \
+ -i agents/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ )
+
+ kde4-meta_src_configure
+}