summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
commitfc673f93b204709bd56426d01fb497d17a231549 (patch)
treea4e35f1a0c18dd58b04ced4408e79f76c9383ffc /kde-frameworks/kauth
parentkde-apps/kalarm: Drop bogus COMMON_DEPEND (diff)
downloadgentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.gz
gentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.bz2
gentoo-fc673f93b204709bd56426d01fb497d17a231549.zip
kde-frameworks: Add KDE Frameworks 5.55.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.55.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index e1e595ba2297..39f1274e02be 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1 +1,2 @@
DIST kauth-5.54.0.tar.xz 84688 BLAKE2B beba564ccc64af52b772ce827b756fad493e3e4926e6bb8b7b65154bf6b7a1753a211e98dd12c67bba844412610ff08f39b9e34a0aadc6c2fc87f4a25e4090bc SHA512 f75c6f019d708409817a5b64d88033326a7d627cdee00e61280043d5cd8f65731f08d48405f50c7240f18670b25abfeea4b2af5966ebb2ee7e0f56669b5551c2
+DIST kauth-5.55.0.tar.xz 84920 BLAKE2B 763a06a4361849c5f75a30b11e76ba99e5173844250b6b75b97560852dc7cd48438d3042a2c4575f9395a3be80215baf2f25a77e8d2e9d5879f2b881417106ab SHA512 fbaeb079ae478d84d9f75c19c3c8cafd105e8fc8648afb1787b61df44862620462ee379edb995f1157c09e70db2aba961ceaa82381fe7c9a05a35e30b103464b
diff --git a/kde-frameworks/kauth/kauth-5.55.0.ebuild b/kde-frameworks/kauth/kauth-5.55.0.ebuild
new file mode 100644
index 000000000000..396d6cb72e1a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.55.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ kde5_src_test
+}