summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-11 12:50:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-11 13:26:17 +0100
commite8116aa13928bb4db16c9bc98858434ad92b6ec7 (patch)
treee4cc968f946b1e06a9cba2e8c260ce8637263270 /kde-frameworks/syntax-highlighting
parentgnome-base/gnome-keyring: remove old (diff)
downloadgentoo-e8116aa13928bb4db16c9bc98858434ad92b6ec7.tar.gz
gentoo-e8116aa13928bb4db16c9bc98858434ad92b6ec7.tar.bz2
gentoo-e8116aa13928bb4db16c9bc98858434ad92b6ec7.zip
kde-frameworks: Add KDE Frameworks 5.66.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.66.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index c8c95ab82699..7f3808204181 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,2 +1,3 @@
DIST syntax-highlighting-5.64.0.tar.xz 1572812 BLAKE2B 5e1b7de3bab10fb912e3c3d0d07d84a6ced1cf12b955a9a09ce4d94f3f150edd05a98334a9373a85f928b1fae8df709b0f51327f600b43402520ffeb9a44071f SHA512 3310651de68409190a203eae1e05bfad1742b656ad66a0f6e49eae9ac00e896300d10780675ca0687982c6dee2fafa5880955c86c67e8149637c8fa52842d4c7
DIST syntax-highlighting-5.65.0.tar.xz 1574720 BLAKE2B 9a9d65109db52beb551582c34e23b224b240ddc9dedf4118d447143cf6d21c5cb65c28a483f17f92abe8fa8481d0bc647e181cb9e42e2687fbfb8e5e084d8441 SHA512 6d47024cc3851c11c9fa774fd2bca0ff8180e0a48e6b08b50e3cdb62d289d688b5736572253b96af62789181df906c9d0642ccdd4d06c545928a342c0d19e5fb
+DIST syntax-highlighting-5.66.0.tar.xz 1579312 BLAKE2B e005660edfd3d0c092d92a27e39a1b0fa5be631260c46b8e6f4121a64455e86b759a8e67e51e26b8a96473bb1740cdc0e617e2195099df2e9ca7d6443b0de1a9 SHA512 7cc68e9eaa3b12f2a5a436115cdc05443640bf1ca1a92c7b66a168605fcafc0e19174a8b28ee0683932e0c097970439e9235a5d55c584ffe56e4cf71e77f2cce
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.66.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.66.0.ebuild
new file mode 100644
index 000000000000..b0f83b80ccf9
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.66.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}