summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-14 22:18:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-14 22:34:14 +0100
commitb52e881a0d82d300e37d28d98856fbd26a79fa71 (patch)
treeb4d209a4f49b44a9351439f44b0fbcf1820d1815 /kde-frameworks
parentkde-frameworks/ktextwidgets: 5.91.0 version bump (diff)
downloadgentoo-b52e881a0d82d300e37d28d98856fbd26a79fa71.tar.gz
gentoo-b52e881a0d82d300e37d28d98856fbd26a79fa71.tar.bz2
gentoo-b52e881a0d82d300e37d28d98856fbd26a79fa71.zip
kde-frameworks/kwallet: 5.91.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.91.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index aeb71f7b5fc1..b8bd52a0877c 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1 +1,2 @@
DIST kwallet-5.90.0.tar.xz 305148 BLAKE2B 8a462f0e1b7944b6f39341c496f5888d2957d45036341da04ab0f3751ef4687bada3340f8528e695100f81e1cc850f976b8aae960b863e3cf6886112ce807123 SHA512 aa8aa252477881c17abfa266fbf8c928c557bc0cedae123e8290a76bc51ed8c2f0f816fc2f4aba9546ce7c776d0080319faf83567fd38cec022022d0c0982af8
+DIST kwallet-5.91.0.tar.xz 305472 BLAKE2B 5244aee1bdb7cf76f9a8391f6135e4ba35273ad6c1f728410ebb7547acceb5b7f45cdf1cb301000ce936eacc071492258722c924665a1466d558a98e41220e02 SHA512 9de1bf99a7772a37f85af6325c4267b42849f1044b4bb536ad5afc979c916d4cc04a8a9b7329f6731d1833ed792a5d772389f470e44637132f6c206a6388bba8
diff --git a/kde-frameworks/kwallet/kwallet-5.91.0.ebuild b/kde-frameworks/kwallet/kwallet-5.91.0.ebuild
new file mode 100644
index 000000000000..5539dcb0ba1a
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.91.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}