summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-10 16:03:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-11 08:53:32 +0200
commit92f560e2949f5c3e1df362878f143885d6d15b4f (patch)
tree1b04994154f4aa116d96f41383c1bf84ee5505b8 /kde-plasma
parentkde-misc/kdiff3: drop 1.11.2-r1 (diff)
downloadgentoo-92f560e2949f5c3e1df362878f143885d6d15b4f.tar.gz
gentoo-92f560e2949f5c3e1df362878f143885d6d15b4f.tar.bz2
gentoo-92f560e2949f5c3e1df362878f143885d6d15b4f.zip
kde-plasma/kinfocenter: Add sys-apps/dmidecode and dev-util/clinfo opts
Closes: https://bugs.gentoo.org/923821 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.27.11-r1.ebuild21
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.1.4.ebuild21
2 files changed, 30 insertions, 12 deletions
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.27.11-r1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.27.11-r1.ebuild
index eee4b3aa6454..c6f477ccd032 100644
--- a/kde-plasma/kinfocenter/kinfocenter-5.27.11-r1.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-5.27.11-r1.ebuild
@@ -76,15 +76,24 @@ src_install() {
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
optfeature "NFS information module" net-fs/nfs-utils
optfeature "Samba status information module" net-fs/samba
- optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
fi
- optfeature "Wayland information module" app-misc/wayland-utils
- optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
- optfeature "OpenGL information module" x11-apps/mesa-progs
- optfeature "PCI devices information module" sys-apps/pciutils
- optfeature "X Server information module" x11-apps/xdpyinfo
ecm_pkg_postinst
}
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.1.4.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.1.4.ebuild
index 63e2962238cb..3bf0f0d92113 100644
--- a/kde-plasma/kinfocenter/kinfocenter-6.1.4.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-6.1.4.ebuild
@@ -73,15 +73,24 @@ src_install() {
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
optfeature "NFS information module" net-fs/nfs-utils
optfeature "Samba status information module" net-fs/samba
- optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
fi
- optfeature "Wayland information module" app-misc/wayland-utils
- optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
- optfeature "OpenGL information module" x11-apps/mesa-progs
- optfeature "PCI devices information module" sys-apps/pciutils
- optfeature "X Server information module" x11-apps/xdpyinfo
ecm_pkg_postinst
}