summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/couriersrs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/couriersrs')
-rw-r--r--mail-filter/couriersrs/Manifest1
-rw-r--r--mail-filter/couriersrs/couriersrs-0.1.2.ebuild29
-rw-r--r--mail-filter/couriersrs/files/couriersrs-0.1.2-automake-fixes.diff36
-rw-r--r--mail-filter/couriersrs/metadata.xml6
4 files changed, 72 insertions, 0 deletions
diff --git a/mail-filter/couriersrs/Manifest b/mail-filter/couriersrs/Manifest
new file mode 100644
index 000000000000..4322dcb80a8c
--- /dev/null
+++ b/mail-filter/couriersrs/Manifest
@@ -0,0 +1 @@
+DIST couriersrs-0.1.2.tar.gz 521868 SHA256 44890a3348f3c6630ec6eca0cc9b2d755d5cce44e100439d22acbb3da6f94109
diff --git a/mail-filter/couriersrs/couriersrs-0.1.2.ebuild b/mail-filter/couriersrs/couriersrs-0.1.2.ebuild
new file mode 100644
index 000000000000..73538fc97866
--- /dev/null
+++ b/mail-filter/couriersrs/couriersrs-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="SRS (Sender Rewriting Scheme) wrapper for the courier MTA"
+HOMEPAGE="http://couriersrs.com/"
+SRC_URI="http://couriersrs.com/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+DEPEND="dev-libs/popt
+ mail-filter/libsrs2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm m4/*.m4
+ epatch "${FILESDIR}/${P}-automake-fixes.diff"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog
+}
diff --git a/mail-filter/couriersrs/files/couriersrs-0.1.2-automake-fixes.diff b/mail-filter/couriersrs/files/couriersrs-0.1.2-automake-fixes.diff
new file mode 100644
index 000000000000..153e5d92c995
--- /dev/null
+++ b/mail-filter/couriersrs/files/couriersrs-0.1.2-automake-fixes.diff
@@ -0,0 +1,36 @@
+--- couriersrs-0.1.2/configure.ac.1 2009-10-11 19:20:07.000000000 +0200
++++ couriersrs-0.1.2/configure.ac 2009-10-11 19:30:35.000000000 +0200
+@@ -16,7 +16,7 @@
+ AM_ICONV
+
+ AM_GNU_GETTEXT
+-AM_GNU_GETTEXT_VERSION(0.14.1)
++AM_GNU_GETTEXT_VERSION(0.15)
+ ALL_LINGUAS=""
+
+ AC_DISABLE_STATIC
+diff -Naur couriersrs-0.1.1/intl/Makefile.in couriersrs-0.1.1-x/intl/Makefile.in
+--- couriersrs-0.1.1/intl/Makefile.in 2007-03-15 20:59:02.000000000 +0100
++++ couriersrs-0.1.1-x/intl/Makefile.in 2009-09-19 23:36:54.000000000 +0200
+@@ -39,8 +39,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = @mkdir_p@
+
+ l = @INTL_LIBTOOL_SUFFIX_PREFIX@
+
+--- couriersrs-0.1.1/po/Makefile.in.in 2007-03-15 20:59:04.000000000 +0100
++++ couriersrs-0.1.1-x/po/Makefile.in.in 2009-09-19 23:36:00.000000000 +0200
+@@ -28,8 +28,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = @mkdir_p@
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
diff --git a/mail-filter/couriersrs/metadata.xml b/mail-filter/couriersrs/metadata.xml
new file mode 100644
index 000000000000..b507dbb0fd19
--- /dev/null
+++ b/mail-filter/couriersrs/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>