summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-11-03 09:41:36 +0100
committerFabian Groffen <grobian@gentoo.org>2024-11-03 09:45:38 +0100
commit951a43c8f8d9bf06d1bbab99ce76fefc0a2b856b (patch)
tree61e2ebb4767e5ce535fb193fd0ba2a6b3502592f /mail-filter
parentmedia-sound/chuck: bump to 1.5.4.0, dropped 1.5.3.2 (diff)
downloadgentoo-951a43c8f8d9bf06d1bbab99ce76fefc0a2b856b.tar.gz
gentoo-951a43c8f8d9bf06d1bbab99ce76fefc0a2b856b.tar.bz2
gentoo-951a43c8f8d9bf06d1bbab99ce76fefc0a2b856b.zip
mail-filter/opendmarc-1.4.2: version bump
- release including official upstream fix for CVE-2021-34555 - add res_ninit to QA exceptions for musl systems Closes: https://bugs.gentoo.org/923992 Closes: https://bugs.gentoo.org/930505 Bug: https://bugs.gentoo.org/797214 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendmarc/Manifest1
-rw-r--r--mail-filter/opendmarc/opendmarc-1.4.1.1-r6.ebuild2
-rw-r--r--mail-filter/opendmarc/opendmarc-1.4.2.ebuild77
3 files changed, 80 insertions, 0 deletions
diff --git a/mail-filter/opendmarc/Manifest b/mail-filter/opendmarc/Manifest
index 3c2c63829a7c..33a95c4fa001 100644
--- a/mail-filter/opendmarc/Manifest
+++ b/mail-filter/opendmarc/Manifest
@@ -1 +1,2 @@
DIST opendmarc-1.4.1.1.tar.gz 426618 BLAKE2B a74b2623bc35abb5c34f8d1eff737c71af8f5cadfd6a5d0a85adb6536efd2958118f9da25dd9b736dc24563221968c4ee1ff99b101fa30909764563bda2a8d88 SHA512 ee034386c70c75b87ca2fce0849a1a3538e10e0aebfb0fc9dcba6817d2cf71f52aa5586ccaacdee620190c5fbb81498419fb8e8db9fac15d7c71a61a7da396a6
+DIST opendmarc-1.4.2.tar.gz 426996 BLAKE2B 71b9bb9e951f0a0c8b15f60c751704b7e01c8536066c413296cec52cd179222008081c57e045d203d90b45b7da6cff8c3f974d5897527b28043387f81b121cb7 SHA512 415278c6c09460379538ad10ea4033815a677ddad138b8a07609c287360d1739acdba5d1fe07d0e35764850af8a141c0c70a9311254104b93d2c1bbc8b6f7a69
diff --git a/mail-filter/opendmarc/opendmarc-1.4.1.1-r6.ebuild b/mail-filter/opendmarc/opendmarc-1.4.1.1-r6.ebuild
index 9dc86350ff33..ea28ad08ceaf 100644
--- a/mail-filter/opendmarc/opendmarc-1.4.1.1-r6.ebuild
+++ b/mail-filter/opendmarc/opendmarc-1.4.1.1-r6.ebuild
@@ -33,6 +33,8 @@ PATCHES=(
)
QA_CONFIG_IMPL_DECL_SKIP=(
+ # musl has no re-entrant variants of these, which configure checks for
+ res_ninit
res_ndestroy
)
diff --git a/mail-filter/opendmarc/opendmarc-1.4.2.ebuild b/mail-filter/opendmarc/opendmarc-1.4.2.ebuild
new file mode 100644
index 000000000000..7fdb5f3fb1af
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.4.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Open source DMARC implementation"
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="https://github.com/trusteddomainproject/OpenDMARC/archive/rel-${PN}-${PV//./-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/OpenDMARC-rel-${PN}-${PV//./-}"
+
+LICENSE="BSD"
+SLOT="0/3" # 1.4 has API breakage with 1.3, yet uses same soname
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="spf +reports"
+
+DEPEND="mail-filter/libmilter:=
+ reports? ( dev-perl/DBI )"
+RDEPEND="${DEPEND}
+ acct-user/opendmarc
+ reports? (
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Message
+ dev-perl/JSON
+ dev-perl/Switch
+ )
+ spf? ( mail-filter/libspf2 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1.1-underlinking.patch
+ "${FILESDIR}"/${PN}-1.4.1.1-arc-seal-crash.patch
+)
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # musl has no re-entrant variants of these, which configure checks for
+ res_ninit
+ res_ndestroy
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+ if use !reports ; then
+ sed -i -e '/^SUBDIRS =/s/reports//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with spf) \
+ $(use_with spf spf2-include "${EPREFIX}"/usr/include/spf2) \
+ $(use_with spf spf2-lib "${EPREFIX}"/usr/$(get_libdir))
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ dodir /etc/opendmarc
+
+ # create config file
+ sed \
+ -e 's:^# UserID .*$:UserID opendmarc:' \
+ -e "s:^# PidFile .*:PidFile ${EPREFIX}/var/run/opendmarc/opendmarc.pid:" \
+ -e '/^# Socket /s:^# ::' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}