summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 01:32:55 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:38 +0000
commitedf40dd3bc4da4b252246c91c7974473f2ddbdbe (patch)
treeba599f1a941155cdb638dd650eb3f46852c8492c /mate-base
parentmate-base/mate: add 1.27.0 (diff)
downloadgentoo-edf40dd3bc4da4b252246c91c7974473f2ddbdbe.tar.gz
gentoo-edf40dd3bc4da4b252246c91c7974473f2ddbdbe.tar.bz2
gentoo-edf40dd3bc4da4b252246c91c7974473f2ddbdbe.zip
mate-base/mate-applets: add 1.27.1
Also drop unneeded ipv6 flag and fix gtksourceview depend Closes: https://bugs.gentoo.org/919089 Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-applets/Manifest1
-rw-r--r--mate-base/mate-applets/mate-applets-1.27.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/mate-base/mate-applets/Manifest b/mate-base/mate-applets/Manifest
index 7f1f8a755c26..8881c6436498 100644
--- a/mate-base/mate-applets/Manifest
+++ b/mate-base/mate-applets/Manifest
@@ -1,2 +1,3 @@
DIST mate-applets-1.26.0.tar.xz 8442720 BLAKE2B b7e3d9cf868926c13652e93b214317c59f7693f3cedc277d2f8e676892bde026587893faabbfff1c6d35af2e6e7f900c3b71d89fc4a8065ff794d1be6e0e4f99 SHA512 4b7676afd8a3ca9e2389f3775abcad5e84bfd628394e98c66c1e77a99503f4893bfd5c8839d63e6044b1b11990aa1d6f7fa857522c1907461ee7b1f68efc7192
DIST mate-applets-1.26.1.tar.xz 8475672 BLAKE2B 0f67f7dfd649c6168f51673f04287e49717ebf7077da63a631844594658d78079df55fd4d25e2be5e299c00d2ea3659ae23140bb508adc327b7c87a74ac4dd19 SHA512 7243825098f9101542b9eead2f60ac7f12e044ceb685da92a29fe72b2dc1271e1fa34dbc4c47148e2331a2af79d69f787dc8856c7112b75ef0a3dea97e4ab8fd
+DIST mate-applets-1.27.1.tar.xz 8506028 BLAKE2B 9c817be243f756bcb97ad4d8f764946b7fc770ff84fed94d2c9fd6e8316f619ad75c585e5447ae2c0803cecf04e4f4a347b1f88dcf6942295ae98b9908a2e341 SHA512 cbdfa745624a14d07f76cb57a1466ec71757b93ad594a12efbb8bc7b05e69491be7d00940a1eec0d876887072cb50456e30bb930a430383685926edbc767285b
diff --git a/mate-base/mate-applets/mate-applets-1.27.1.ebuild b/mate-base/mate-applets/mate-applets-1.27.1.ebuild
new file mode 100644
index 000000000000..9aed13a18ec0
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.27.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="CC-BY-SA-3.0 FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +cpupower netlink policykit +upower"
+
+REQUIRED_USE="policykit? ( cpupower )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ >=dev-libs/libxml2-2.5:2
+ >=gnome-base/libgtop-2.12.0:2=
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=mate-base/mate-panel-1.25.2
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.10.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/gtksourceview
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ >=x11-libs/libwnck-3.0:3
+ x11-libs/pango
+ cpupower? (
+ sys-power/cpupower
+ policykit? ( >=sys-auth/polkit-0.97:0 )
+ )
+ netlink? (
+ dev-libs/libnl:3
+ )
+ upower? ( >=sys-power/upower-0.99.8 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ mate-base/caja
+ mate-base/mate-desktop
+ >=mate-base/mate-settings-daemon-1.6
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+
+ # configure.ac logic is a little hinky
+ # and ignores --enable flags for cpufreq
+ use cpupower || myconf="--disable-cpufreq"
+
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_with netlink nl) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}