summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/zh-kcfonts/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/zh-kcfonts/files')
-rw-r--r--media-fonts/zh-kcfonts/files/kcfonts-1.05-code-fixups.patch181
-rw-r--r--media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch11
2 files changed, 192 insertions, 0 deletions
diff --git a/media-fonts/zh-kcfonts/files/kcfonts-1.05-code-fixups.patch b/media-fonts/zh-kcfonts/files/kcfonts-1.05-code-fixups.patch
new file mode 100644
index 000000000000..2acf25bd8f0a
--- /dev/null
+++ b/media-fonts/zh-kcfonts/files/kcfonts-1.05-code-fixups.patch
@@ -0,0 +1,181 @@
+Written by Robin H. Johnson <robbat2@gentoo.org>.
+
+This patch is meant as additional to the FreeBSD patches aa-ad.
+1. Cleans up the Makefile so that it is properly parallel.
+2. Makefile now tracks errors correctly (piped errors are lost to Make).
+3. Fixes bugs in the code that caused glibc's corruption detection to trigger.
+4. Fixes code so it should mostly compile on gcc4.
+
+diff -Nuar kcfonts-1.05.orig/Makefile kcfonts-1.05/Makefile
+--- kcfonts-1.05.orig/Makefile 2006-01-11 16:33:36.976771750 -0800
++++ kcfonts-1.05/Makefile 2006-01-11 16:32:31.416674500 -0800
+@@ -16,20 +16,25 @@
+
+ all: $(FONTS)
+
+-kc24f.pcf.gz: kc24f
+- ./kc24f | bdftopcf | gzip - > kc24f.pcf.gz
+-kc15f.pcf.gz: kc15f
+- ./kc15f | bdftopcf | gzip - > kc15f.pcf.gz
+-kc8x15.pcf.gz: kca2et kc8x15
++.SECONDARY: $(FONTS:.pcf.gz=.pcf)
++
++%.pcf: %.bdf
++ bdftopcf $< -o $@
++%.pcf.gz: %.pcf
++ gzip -9 < $< > $@
++
++kc24f.bdf: kc24f
++ ./kc24f > kc24f.bdf
++kc15f.bdf: kc15f
++ ./kc15f >kc15f.bdf
++kc8x15.bdf: kca2et kc8x15
+ ./kca2et kctext16.f00 ascfont.15 256 16 15
+ ./kc8x15 > kc8x15.bdf
+ patch < kc8x15.diff
+- bdftopcf kc8x15.bdf | gzip - > kc8x15.pcf.gz
+-kc12x24.pcf.gz: kca2et kc12x24
++kc12x24.bdf: kca2et kc12x24
+ ./kca2et kctext24.f00 ascfont.24 256 48 48
+ ./kc12x24 > kc12x24.bdf
+ patch < kc12x24.diff
+- bdftopcf kc12x24.bdf | gzip - > kc12x24.pcf.gz
+
+ kc24f: tran.o kc24f.o
+ $(CC) $(CFLAGS) tran.o kc24f.o -o $@
+@@ -52,4 +57,4 @@
+ mkfontdir $(EFONTDIR)
+
+ clean:
+- rm -f kc*.pcf.gz ascfont.* *.o *~ $(PROGS)
++ rm -f kc*.pcf.gz ascfont.* *.o *~ $(PROGS) *.pcf *.bdf
+diff -Nuar kcfonts-1.05.orig/kc12x24.c kcfonts-1.05/kc12x24.c
+--- kcfonts-1.05.orig/kc12x24.c 2006-01-11 16:33:36.980772000 -0800
++++ kcfonts-1.05/kc12x24.c 2006-01-11 16:34:33.300291750 -0800
+@@ -6,6 +6,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ char bdfhead[]=
+ "STARTFONT 2.1\n"
+diff -Nuar kcfonts-1.05.orig/kc15f.c kcfonts-1.05/kc15f.c
+--- kcfonts-1.05.orig/kc15f.c 2006-01-11 16:33:36.980772000 -0800
++++ kcfonts-1.05/kc15f.c 2006-01-11 16:36:44.316479750 -0800
+@@ -8,6 +8,8 @@
+
+ #include <stdio.h>
+ #include <sys/types.h>
++#include <stdlib.h>
++#include "tran.h"
+
+ char head[]=
+ "STARTFONT 2.1\n"
+@@ -66,7 +68,7 @@
+ fprintf(stdout,"ENDCHAR\n");
+ }
+
+-main()
++int main()
+ {
+
+ if ((fp=fopen("spcfont.15","r"))==NULL) {
+@@ -111,5 +113,8 @@
+
+ fprintf(stdout,"ENDFONT\n");
+
+- fclose(fp);
++ // fp points to f2, which is either closed or already invalid here.
++ // We don't care about leaking a single fd this late anyway
++ //fclose(fp);
++ return 0;
+ }
+diff -Nuar kcfonts-1.05.orig/kc24f.c kcfonts-1.05/kc24f.c
+--- kcfonts-1.05.orig/kc24f.c 2006-01-11 16:33:36.980772000 -0800
++++ kcfonts-1.05/kc24f.c 2006-01-11 16:37:14.438362250 -0800
+@@ -7,6 +7,8 @@
+
+ #include <stdio.h>
+ #include <sys/types.h>
++#include <stdlib.h>
++#include "tran.h"
+
+ char head[]=
+ "STARTFONT 2.1\n"
+@@ -45,7 +47,7 @@
+ {
+ u_char tt[3],uu[3];
+ u_char bf[24][3];
+-int v,i,j,zc;
++int v,i,zc;
+
+
+ if ((v=fread(bf,1,72,fp)) != 72) return;
+@@ -66,7 +68,7 @@
+ fprintf(stdout,"ENDCHAR\n");
+ }
+
+-main()
++int main()
+ {
+
+ if ((fp=fopen("spcfont.24","r"))==NULL) {
+@@ -110,5 +112,8 @@
+
+ fprintf(stdout,"ENDFONT\n");
+
+-fclose(fp);
++// fp points to f2, which is either closed or already invalid here.
++// We don't care about leaking a single fd this late anyway
++//fclose(fp);
++return 0;
+ }
+diff -Nuar kcfonts-1.05.orig/kc8x15.c kcfonts-1.05/kc8x15.c
+--- kcfonts-1.05.orig/kc8x15.c 2006-01-11 16:33:36.980772000 -0800
++++ kcfonts-1.05/kc8x15.c 2006-01-11 16:34:43.984959500 -0800
+@@ -6,6 +6,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ char bdfhead[]=
+ "STARTFONT 2.1\n"
+diff -Nuar kcfonts-1.05.orig/kca2et.c kcfonts-1.05/kca2et.c
+--- kcfonts-1.05.orig/kca2et.c 1995-12-16 09:22:25.000000000 -0800
++++ kcfonts-1.05/kca2et.c 2006-01-11 16:35:33.604060500 -0800
+@@ -10,7 +10,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
+-void main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ int i;
+ unsigned char tmp[60];
+@@ -29,5 +29,6 @@
+
+ fclose( fp );
+ fclose( fout );
++ return 0;
+ }
+
+diff -Nuar kcfonts-1.05.orig/tran.c kcfonts-1.05/tran.c
+--- kcfonts-1.05.orig/tran.c 1995-12-16 09:22:06.000000000 -0800
++++ kcfonts-1.05/tran.c 2006-01-11 16:18:10.186851000 -0800
+@@ -4,6 +4,7 @@
+ */
+
+ #include <sys/types.h>
++#include <stdio.h>
+
+ void ser_b5(u_char *ch, u_char *tt)
+ {
+diff -Nuar kcfonts-1.05.orig/tran.h kcfonts-1.05/tran.h
+--- kcfonts-1.05.orig/tran.h 1969-12-31 16:00:00.000000000 -0800
++++ kcfonts-1.05/tran.h 2006-01-11 16:36:26.099341250 -0800
+@@ -0,0 +1,3 @@
++#include <sys/types.h>
++void ser_b5(u_char *ch, u_char *tt);
++void b5_ser(u_char *s, u_char *t);
diff --git a/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch b/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
new file mode 100644
index 000000000000..93fc8ed9608e
--- /dev/null
+++ b/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-01-01 10:45:14.000000000 +0900
++++ Makefile 2009-01-01 10:45:32.000000000 +0900
+@@ -31,7 +31,7 @@
+ $(CC) $(CFLAGS) tran.o kc24f.o -o $@
+ kc15f: tran.o kc15f.o
+ $(CC) $(CFLAGS) tran.o kc15f.o -o $@
+-kc8x15: kc8x15.o
++kc8x15: tran.o kc8x15.o
+ $(CC) $(CFLAGS) tran.o kc8x15.o -o $@
+ kc12x24: kc12x24.o
+ $(CC) $(CFLAGS) kc12x24.o -o $@