summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-20 17:29:03 +1000
committerSam James <sam@gentoo.org>2020-08-24 14:41:56 +0100
commit5ffd98d291730cc22e4cbbc6e4ae717fbb17f282 (patch)
treed161499a6c1fd1d0a77996de51b16a94172a44d6 /media-gfx/blender
parentmedia-gfx/blender: Version bump to 2.83.4 (diff)
downloadgentoo-5ffd98d291730cc22e4cbbc6e4ae717fbb17f282.tar.gz
gentoo-5ffd98d291730cc22e4cbbc6e4ae717fbb17f282.tar.bz2
gentoo-5ffd98d291730cc22e4cbbc6e4ae717fbb17f282.zip
media-gfx/blender: Blender with openvdb requires openvdb-7.0.0 only
Compiling blender with openvdb fails using openvdb-7.1.0, as std::make_unique is not available in c++11. Upgrading to newer c++ was discussed upstream and it was decided to remain with c++11 now, in keeping with the VFX reference platform, and update to c++17 in 2021. See https://developer.blender.org/T76783 Openvdb 7.0.0 uses c++11, whereas 7.1.0 uses c++14. So it will not be possible to use versions 7.1.0 and above until blender updates to c++14 or higher next year. Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/blender')
-rw-r--r--media-gfx/blender/blender-2.79b-r2.ebuild4
-rw-r--r--media-gfx/blender/blender-2.83.4.ebuild2
-rw-r--r--media-gfx/blender/files/blender-fix-install-rules.patch16
3 files changed, 19 insertions, 3 deletions
diff --git a/media-gfx/blender/blender-2.79b-r2.ebuild b/media-gfx/blender/blender-2.79b-r2.ebuild
index 1b08a01395b6..977f12110a6a 100644
--- a/media-gfx/blender/blender-2.79b-r2.ebuild
+++ b/media-gfx/blender/blender-2.79b-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python3_6 )
-inherit check-reqs cmake-utils xdg-utils flag-o-matic xdg-utils \
+inherit check-reqs cmake-utils flag-o-matic xdg-utils \
pax-utils python-single-r1 toolchain-funcs eapi7-ver
DESCRIPTION="3D Creation/Animation/Publishing System"
@@ -77,7 +77,7 @@ RDEPEND="${PYTHON_DEPS}
)
opensubdiv? ( >=media-libs/opensubdiv-3.3.0:=[cuda=,opencl=] )
openvdb? (
- media-gfx/openvdb[abi4-compat]
+ <media-gfx/openvdb-7[abi4-compat]
dev-cpp/tbb
>=dev-libs/c-blosc-1.5.2
)
diff --git a/media-gfx/blender/blender-2.83.4.ebuild b/media-gfx/blender/blender-2.83.4.ebuild
index de3ba5896dcb..b6e7cb00c608 100644
--- a/media-gfx/blender/blender-2.83.4.ebuild
+++ b/media-gfx/blender/blender-2.83.4.ebuild
@@ -85,7 +85,7 @@ RDEPEND="${PYTHON_DEPS}
)
opensubdiv? ( >=media-libs/opensubdiv-3.4.0[cuda=,opencl=] )
openvdb? (
- >=media-gfx/openvdb-7.0.0[abi6-compat(-)?,abi7-compat(-)?]
+ ~media-gfx/openvdb-7.0.0[abi6-compat(-)?,abi7-compat(-)?]
dev-cpp/tbb
dev-libs/c-blosc:=
)
diff --git a/media-gfx/blender/files/blender-fix-install-rules.patch b/media-gfx/blender/files/blender-fix-install-rules.patch
new file mode 100644
index 000000000000..e62aba814b9f
--- /dev/null
+++ b/media-gfx/blender/files/blender-fix-install-rules.patch
@@ -0,0 +1,16 @@
+diff -purN a/source/creator/CMakeLists.txt b/source/creator/CMakeLists.txt
+--- a/source/creator/CMakeLists.txt 2016-09-28 10:26:55.000000000 +0100
++++ b/source/creator/CMakeLists.txt 2016-10-03 12:17:08.938928486 +0100
+@@ -328,12 +328,6 @@ endif()
+ # Install Targets (Generic, All Platforms)
+
+
+-# important to make a clean install each time, else old scripts get loaded.
+-install(
+- CODE
+- "file(REMOVE_RECURSE ${TARGETDIR_VER})"
+-)
+-
+ if(WITH_PYTHON)
+ # install(CODE "message(\"copying blender scripts...\")")
+