summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-01 21:08:04 +1100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-01 21:08:32 +1100
commite1a59a083d1232dcfaf429929cee44049efb9771 (patch)
tree81045da85daaff6901f4e8c2211b54df3247f7fa /media-gfx/jhead
parentsci-libs/linux-gpib: Add call to udev_reload (diff)
downloadgentoo-e1a59a083d1232dcfaf429929cee44049efb9771.tar.gz
gentoo-e1a59a083d1232dcfaf429929cee44049efb9771.tar.bz2
gentoo-e1a59a083d1232dcfaf429929cee44049efb9771.zip
media-gfx/jhead: drop 3.06.0.1-r1
Bug: https://bugs.gentoo.org/908519 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/Manifest1
-rw-r--r--media-gfx/jhead/files/jhead-3.06.0.1-CVE-2021-34055.patch108
-rw-r--r--media-gfx/jhead/files/jhead-3.06.0.1-mkstemp-fix-makefile.patch52
-rw-r--r--media-gfx/jhead/jhead-3.06.0.1-r1.ebuild27
4 files changed, 0 insertions, 188 deletions
diff --git a/media-gfx/jhead/Manifest b/media-gfx/jhead/Manifest
index d2f781c90eac..6a884cfb9bdd 100644
--- a/media-gfx/jhead/Manifest
+++ b/media-gfx/jhead/Manifest
@@ -1,2 +1 @@
-DIST jhead-3.06.0.1.tgz 1144608 BLAKE2B 100eaddd8585e8845e83c3eb24aefb0a0a2d477f0ee818c212cc39ad88f39cbac5532979dbe7ee8c4d7b9475fdf4cce4257679d996e4fae14ef1902ef2f8e5a2 SHA512 7804f4bab1b07eb08ed981364b3634b1c25e0657d57651871aede640254c33f9d2307ba7c9fb3bc81eb06b71ba5d27437275a3fe53859e9e9457e37e12545db9
DIST jhead-3.08.tgz 1146535 BLAKE2B 8e53fed1988c12be40b804fd3c8aa51d71ddaa11d97ed11479ec100f26585cc4a19b3b29249642e1cdb5afbf612b6b4281c4f0ec3ad10ad1a6e6fdffc6729740 SHA512 eb50e487eaacf2b489ce5e76f09730c8bb0c50a0e2d7c854ebe8bd204ead8f6256e052c49c72af179dc46dd5372c1eff32ff549b947637b242dc7bbe8c7b20d5
diff --git a/media-gfx/jhead/files/jhead-3.06.0.1-CVE-2021-34055.patch b/media-gfx/jhead/files/jhead-3.06.0.1-CVE-2021-34055.patch
deleted file mode 100644
index 1669eb6f089f..000000000000
--- a/media-gfx/jhead/files/jhead-3.06.0.1-CVE-2021-34055.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-From f4f57913fff5de97da347a22558bbb74a1166369 Mon Sep 17 00:00:00 2001
-From: matthias wandel <matthias@woodgears.ca>
-Date: Wed, 1 Sep 2021 18:59:15 -0300
-Subject: [PATCH] If exif header is complete garbage, don't keep it. Fixes
- issue 36
-
-(cherry picked from commit c761620767ae72e5d61c697a73de262aebe0b591)
----
- exif.c | 12 +++++++-----
- jhead.h | 2 +-
- jpgfile.c | 5 ++++-
- 3 files changed, 12 insertions(+), 7 deletions(-)
-
-diff --git a/exif.c b/exif.c
-index ba066b5..d250a8d 100755
---- a/exif.c
-+++ b/exif.c
-@@ -1005,7 +1005,7 @@ void Clear_EXIF ()
- // Process a EXIF marker
- // Describes all the drivel that most digital cameras include...
- //--------------------------------------------------------------------------
--void process_EXIF (unsigned char * ExifSection, int length)
-+int process_EXIF (unsigned char * ExifSection, int length)
- {
- int FirstOffset;
-
-@@ -1020,7 +1020,7 @@ void process_EXIF (unsigned char * ExifSection, int length)
- static uchar ExifHeader[] = "Exif\0\0";
- if (memcmp(ExifSection+2, ExifHeader,6)){
- ErrNonfatal("Incorrect Exif header",0,0);
-- return;
-+ return 0;
- }
- }
-
-@@ -1033,21 +1033,21 @@ void process_EXIF (unsigned char * ExifSection, int length)
- MotorolaOrder = 1;
- }else{
- ErrNonfatal("Invalid Exif alignment marker.",0,0);
-- return;
-+ return 0;
- }
- }
-
- // Check the next value for correctness.
- if (Get16u(ExifSection+10) != 0x2a){
- ErrNonfatal("Invalid Exif start (1)",0,0);
-- return;
-+ return 0;
- }
-
- FirstOffset = (int)Get32u(ExifSection+12);
- if (FirstOffset < 8 || FirstOffset > 16){
- if (FirstOffset < 16 || FirstOffset > length-16 || length < 16){
- ErrNonfatal("invalid offset for first Exif IFD value",0,0);
-- return;
-+ return 0;
- }
- // Usually set to 8, but other values valid too.
- ErrNonfatal("Suspicious offset of first Exif IFD value",0,0);
-@@ -1086,6 +1086,7 @@ void process_EXIF (unsigned char * ExifSection, int length)
- ImageInfo.FocalLength35mmEquiv = (int)(ImageInfo.FocalLength/ImageInfo.CCDWidth*36 + 0.5);
- }
- }
-+ return 1;
- }
-
-
-@@ -1235,6 +1236,7 @@ void create_EXIF(void)
- const char * ClearOrientation(void)
- {
- int a;
-+
- if (NumOrientations == 0) return NULL;
-
- for (a=0;a<NumOrientations;a++){
-diff --git a/jhead.h b/jhead.h
-index 3d620d9..03987e2 100644
---- a/jhead.h
-+++ b/jhead.h
-@@ -163,7 +163,7 @@ void FileTimeAsString(char * TimeStr);
- // Prototypes for exif.c functions.
- int Exif2tm(struct tm * timeptr, char * ExifTime);
- void Clear_EXIF();
--void process_EXIF (unsigned char * CharBuf, int length);
-+int process_EXIF (unsigned char * CharBuf, int length);
- void ShowImageInfo(int ShowFileInfo);
- void ShowConciseImageInfo(void);
- const char * ClearOrientation(void);
-diff --git a/jpgfile.c b/jpgfile.c
-index 097d2f1..af2d7bc 100644
---- a/jpgfile.c
-+++ b/jpgfile.c
-@@ -286,7 +286,10 @@ int ReadJpegSections (FILE * infile, ReadMode_t ReadMode)
- // There can be different section using the same marker.
- if (ReadMode & READ_METADATA){
- if (memcmp(Data+2, "Exif", 4) == 0){
-- process_EXIF(Data, itemlen);
-+ if (!process_EXIF(Data, itemlen)){
-+ // malformatted exif sections, discard.
-+ free(Sections[--SectionsRead].Data);
-+ }
- break;
- }else if (memcmp(Data+2, "http:", 5) == 0){
- Sections[SectionsRead-1].Type = M_XMP; // Change tag for internal purposes.
---
-2.39.2
-
diff --git a/media-gfx/jhead/files/jhead-3.06.0.1-mkstemp-fix-makefile.patch b/media-gfx/jhead/files/jhead-3.06.0.1-mkstemp-fix-makefile.patch
deleted file mode 100644
index d25323d4ab38..000000000000
--- a/media-gfx/jhead/files/jhead-3.06.0.1-mkstemp-fix-makefile.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -ruN jhead-3.06.0.1.orig/jhead.c jhead-3.06.0.1/jhead.c
---- jhead-3.06.0.1.orig/jhead.c 2021-04-14 14:02:45.000000000 +0200
-+++ jhead-3.06.0.1/jhead.c 2022-10-09 00:25:03.812585996 +0200
-@@ -377,7 +377,7 @@
- // as mktemp - that is, that between getting the random name, and making the file
- // some other program could snatch that exact same name!
- // also, not all platforms support mkstemp.
-- mktemp(TempName);
-+ mkstemp(TempName);
-
-
- if(!TempName[0]) {
-diff -ruN jhead-3.06.0.1.orig/makefile jhead-3.06.0.1/makefile
---- jhead-3.06.0.1.orig/makefile 2021-04-14 14:02:45.000000000 +0200
-+++ jhead-3.06.0.1/makefile 2022-10-09 00:27:28.659543801 +0200
-@@ -3,10 +3,14 @@
- #--------------------------------
- OBJ=obj
- SRC=.
--CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
--LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
-+LFLAGS = -fPIC -shared -Wl,-soname,libjhead.so.1
-
--all: objdir jhead
-+TARGET = libjhead.so.1.0.0
-+TARGET0 = libjhead.so
-+TARGET1 = libjhead.so.1
-+TARGET2 = libjhead.so.1.0
-+
-+all: objdir jhead $(TARGET)
-
- objdir:
- @mkdir -p obj
-@@ -15,7 +19,7 @@
- $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
-
- $(OBJ)/%.o:$(SRC)/%.c
-- ${CC} $(CFLAGS) -c $< -o $@
-+ ${CC} -fPIC $(CFLAGS) -c $< -o $@
-
- jhead: $(objs) jhead.h
- ${CC} $(LDFLAGS) -o jhead $(objs) -lm
-@@ -26,3 +30,9 @@
- install:
- mkdir -p ${DESTDIR}/usr/bin/
- cp jhead ${DESTDIR}/usr/bin/
-+
-+$(TARGET): $(objs) jhead
-+ ${CC} $(LDFLAGS) $(LFLAGS) -o $(TARGET) $(objs)
-+ ln -s ${TARGET} ${TARGET0}
-+ ln -s ${TARGET} ${TARGET1}
-+ ln -s ${TARGET} ${TARGET2}
diff --git a/media-gfx/jhead/jhead-3.06.0.1-r1.ebuild b/media-gfx/jhead/jhead-3.06.0.1-r1.ebuild
deleted file mode 100644
index 4a79de66ceee..000000000000
--- a/media-gfx/jhead/jhead-3.06.0.1-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
-HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
-SRC_URI="https://github.com/Matthias-Wandel/jhead/archive/refs/tags/${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
-
-PATCHES=(
- "${FILESDIR}/${P}-mkstemp-fix-makefile.patch"
- "${FILESDIR}/${P}-CVE-2021-34055.patch"
-)
-
-src_install() {
- dobin ${PN}
- dodoc *.txt
- docinto html
- dodoc *.html
- doman ${PN}.1
- doheader ${PN}.h
- dolib.so lib${PN}.so*
-}