summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 17:42:13 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:57 +0100
commit4337dd163c56306eb93d84d12f02cc7769a76470 (patch)
tree229bc589221ff7b046766af3ae23fb650548a959 /media-gfx/png2ico/png2ico-2002.12.08.ebuild
parentmedia-gfx/pngnq: port to EAPI 7 (diff)
downloadgentoo-4337dd163c56306eb93d84d12f02cc7769a76470.tar.gz
gentoo-4337dd163c56306eb93d84d12f02cc7769a76470.tar.bz2
gentoo-4337dd163c56306eb93d84d12f02cc7769a76470.zip
media-gfx/png2ico: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/png2ico/png2ico-2002.12.08.ebuild')
-rw-r--r--media-gfx/png2ico/png2ico-2002.12.08.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/media-gfx/png2ico/png2ico-2002.12.08.ebuild b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
index 8392b54d6800..1a732423a74a 100644
--- a/media-gfx/png2ico/png2ico-2002.12.08.ebuild
+++ b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
@@ -1,26 +1,31 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="PNG to icon converter"
HOMEPAGE="http://winterdrache.de/freeware/png2ico/index.html"
SRC_URI="http://winterdrache.de/freeware/${PN}/data/${PN}-src-${PV/./-}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="media-libs/libpng:0=
- sys-libs/zlib:="
+RDEPEND="
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${P}-memset_and_strcmp.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-memset_and_strcmp.patch
+ default
sed -i \
-e 's:CPPFLAGS=-W -Wall -O2:CXXFLAGS+=-W -Wall:' \