summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/xli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/xli')
-rw-r--r--media-gfx/xli/Manifest1
-rw-r--r--media-gfx/xli/files/Xli.ad2
-rw-r--r--media-gfx/xli/files/xli-1.17.0-fix-scale-zoom.patch61
-rw-r--r--media-gfx/xli/files/xli-1.17.0-libpng14.patch14
-rw-r--r--media-gfx/xli/files/xli-security-gentoo.diff199
-rw-r--r--media-gfx/xli/metadata.xml5
-rw-r--r--media-gfx/xli/xli-1.17.0-r5.ebuild76
7 files changed, 358 insertions, 0 deletions
diff --git a/media-gfx/xli/Manifest b/media-gfx/xli/Manifest
new file mode 100644
index 000000000000..10dcfa588bec
--- /dev/null
+++ b/media-gfx/xli/Manifest
@@ -0,0 +1 @@
+DIST xli-2005-02-27.tar.gz 201011 SHA256 442dcf5ac75841e648c3bffed795d9301a6a485dc55f7998d0acfc2b8daad2bc SHA512 132b28396ebf3832dc35ff5fa7c102539ef30a194512fe6577ce1432bb84ecd7b4368e75eaf59f26a806900f63e1bfb9a93487ce1ebe3cfef2199256a783ccf7 WHIRLPOOL 1d3b45be838d397fdbc2521c9c5a466e4141248591ae00016fa316f67a4ab44bc712896a59581e3f9a2e10cabb56f041ef7a3e21cc2a4f59733dc44d446e541b
diff --git a/media-gfx/xli/files/Xli.ad b/media-gfx/xli/files/Xli.ad
new file mode 100644
index 000000000000..6c9a022e40b6
--- /dev/null
+++ b/media-gfx/xli/files/Xli.ad
@@ -0,0 +1,2 @@
+path=/usr/X11R6/include/X11/bitmaps /usr/X11R6/include/X11/images
+extension=.gif .jpg .rle .csun .msun .sun .face .xbm .bm
diff --git a/media-gfx/xli/files/xli-1.17.0-fix-scale-zoom.patch b/media-gfx/xli/files/xli-1.17.0-fix-scale-zoom.patch
new file mode 100644
index 000000000000..44ee262aee25
--- /dev/null
+++ b/media-gfx/xli/files/xli-1.17.0-fix-scale-zoom.patch
@@ -0,0 +1,61 @@
+As of jpeg-7, the scale coefficents may be set to non-unitary values by the
+initial DCT transform. This caused the original already-scale detection
+algorithm in xli to break.
+
+To avoid this, set the already-scaled marker when we adjust the scale fraction
+(that gets passed into the DCT).
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar -X x xli-2005-02-27.orig/jpeg.c xli-2005-02-27/jpeg.c
+--- xli-2005-02-27.orig/jpeg.c 2005-02-27 16:42:39.000000000 -0800
++++ xli-2005-02-27/jpeg.c 2009-09-05 15:02:12.462635389 -0700
+@@ -211,7 +211,7 @@
+ xli_jpg_err jerr;
+ Image *image = 0;
+ byte **rows = 0;
+- int i, rowbytes;
++ int i, rowbytes, flags;
+
+ CURRFUNC("jpegLoad");
+ zfp = zopen(fullname);
+@@ -248,9 +248,13 @@
+ if (verbose)
+ describe_jpeg(&cinfo, fullname);
+
++ flags = 0;
+ if (image_ops->iscale > 0 && image_ops->iscale < 4) {
+- cinfo.scale_num = 1;
+- cinfo.scale_denom = 1 << image_ops->iscale;
++ flags |= FLAG_ISCALE;
++ //cinfo.scale_num = 1;
++ cinfo.scale_denom *= 1 << image_ops->iscale;
++ if (verbose)
++ printf("scaling to %d/%d\n", cinfo.scale_num, cinfo.scale_denom);
+ } else if (image_ops->iscale_auto) {
+ image_ops->iscale = 0;
+ while (image_ops->iscale < 3 && (cinfo.image_width >>
+@@ -258,9 +262,11 @@
+ cinfo.image_height >> image_ops->iscale >
+ globals.dinfo.height * .9))
+ image_ops->iscale += 1;
+- cinfo.scale_denom = 1 << image_ops->iscale;
++ cinfo.scale_denom *= 1 << image_ops->iscale;
++ if(image_ops->iscale > 0)
++ flags |= FLAG_ISCALE;
+ if (verbose)
+- printf("auto-scaling to 1/%d\n", cinfo.scale_denom);
++ printf("auto-scaling to %d/%d\n", cinfo.scale_num, cinfo.scale_denom);
+ }
+ znocache(zfp);
+
+@@ -288,8 +294,7 @@
+ }
+
+ image->gamma = RETURN_GAMMA;
+- if (cinfo.scale_denom > 1)
+- image->flags |= FLAG_ISCALE;
++ image->flags |= flags;
+
+ rowbytes = cinfo.output_width * cinfo.output_components;
+ assert(image->pixlen * image->width == rowbytes);
diff --git a/media-gfx/xli/files/xli-1.17.0-libpng14.patch b/media-gfx/xli/files/xli-1.17.0-libpng14.patch
new file mode 100644
index 000000000000..afb4b24208d7
--- /dev/null
+++ b/media-gfx/xli/files/xli-1.17.0-libpng14.patch
@@ -0,0 +1,14 @@
+http://aur.archlinux.org/packages.php?ID=1676
+http://archwyrm.net/~me/xli-libpng.diff
+
+--- png.c
++++ png.c
+@@ -27,7 +27,7 @@
+ if (ret != 8)
+ return 0;
+
+- ret = png_check_sig(buf, 8);
++ ret = !png_sig_cmp(buf, 0, 8);
+
+ return (ret);
+ }
diff --git a/media-gfx/xli/files/xli-security-gentoo.diff b/media-gfx/xli/files/xli-security-gentoo.diff
new file mode 100644
index 000000000000..7425e67c7c74
--- /dev/null
+++ b/media-gfx/xli/files/xli-security-gentoo.diff
@@ -0,0 +1,199 @@
+diff -Nrup xli-2005-02-27/imagetypes.c xli-2005-02-27/imagetypes.c
+--- xli-2005-02-27/imagetypes.c 1999-10-24 22:14:57.000000000 -0400
++++ xli-2005-02-27/imagetypes.c 2005-10-18 07:53:46.000000000 -0400
+@@ -53,7 +53,7 @@ Image *loadImage(ImageOptions * image_op
+ Image *image;
+ int a;
+
+- if (findImage(image_ops->name, fullname) < 0) {
++ if (findImage(image_ops->name, fullname, BUFSIZ) < 0) {
+ if (errno == ENOENT)
+ printf("%s: image not found\n", image_ops->name);
+ else if (errno == EISDIR)
+@@ -95,7 +95,7 @@ void identifyImage(char *name)
+ char fullname[BUFSIZ];
+ int a;
+
+- if (findImage(name, fullname) < 0) {
++ if (findImage(name, fullname, BUFSIZ) < 0) {
+ if (errno == ENOENT)
+ printf("%s: image not found\n", name);
+ else if (errno == EISDIR)
+diff -Nrup xli-2005-02-27/path.c xli-2005-02-27/path.c
+--- xli-2005-02-27/path.c 2005-02-27 19:42:39.000000000 -0500
++++ xli-2005-02-27/path.c 2005-10-18 07:56:45.000000000 -0400
+@@ -172,12 +172,12 @@ static int fileIsOk(char *fullname, stru
+ /* find an image with paths and extensions from defaults files. returns
+ * -1 if access denied or not found, 0 if ok.
+ */
+-int findImage(char *name, char *fullname)
++int findImage(char *name, char *fullname, size_t size)
+ {
+ unsigned int p, e;
+ struct stat sbuf;
+
+- strcpy(fullname, name);
++ strncpy(fullname, name, size);
+ if (!strcmp(name, "stdin")) /* stdin is special name */
+ return (0);
+
+@@ -185,26 +185,26 @@ int findImage(char *name, char *fullname
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #ifndef NO_COMPRESS
+- strcat(fullname, ".Z");
++ strncat(fullname, ".Z", size);
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #endif
+
+ for (p = 0; p < NumPaths; p++) {
+- sprintf(fullname, "%s/%s", Paths[p], name);
++ snprintf(fullname, size, "%s/%s", Paths[p], name);
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #ifndef NO_COMPRESS
+- strcat(fullname, ".Z");
++ strncat(fullname, ".Z", size);
+ if (!stat(fullname, &sbuf))
+ #endif
+ return (fileIsOk(fullname, &sbuf));
+ for (e = 0; e < NumExts; e++) {
+- sprintf(fullname, "%s/%s%s", Paths[p], name, Exts[e]);
++ snprintf(fullname, size, "%s/%s%s", Paths[p], name, Exts[e]);
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #ifndef NO_COMPRESS
+- strcat(fullname, ".Z");
++ strncat(fullname, ".Z", size);
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #endif
+@@ -212,11 +212,11 @@ int findImage(char *name, char *fullname
+ }
+
+ for (e = 0; e < NumExts; e++) {
+- sprintf(fullname, "%s%s", name, Exts[e]);
++ snprintf(fullname, size, "%s%s", name, Exts[e]);
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #ifndef NO_COMPRESS
+- strcat(fullname, ".Z");
++ strncat(fullname, ".Z", size);
+ if (!stat(fullname, &sbuf))
+ return (fileIsOk(fullname, &sbuf));
+ #endif
+@@ -241,7 +241,7 @@ void listImages(void)
+ for (a = 0; a < NumPaths; a++) {
+ printf("%s:\n", Paths[a]);
+ fflush(stdout);
+- sprintf(buf, "ls %s", Paths[a]);
++ snprintf(buf, sizeof(buf)-1, "ls %s", Paths[a]);
+ if (system(buf) < 0) {
+ perror("ls");
+ return;
+@@ -296,14 +296,14 @@ char *expandPath(char *p)
+ var++;
+ else if (*p == '~') {
+ buf1[b1] = '\0';
+- strcat(buf1, getenv("HOME"));
++ strncat(buf1, getenv("HOME"), sizeof(buf1)-1);
+ b1 = strlen(buf1);
+ var = 0;
+ } else if (*p == '/' || *p == '}') {
+ if (var) {
+ buf1[b1] = '\0';
+ buf2[b2] = '\0';
+- strcat(buf1, getenv(buf2));
++ strncat(buf1, getenv(buf2), sizeof(buf1));
+ b1 = strlen(buf1);
+ buf2[0] = '\0';
+ b2 = 0;
+diff -Nrup xli-2005-02-27/reduce.c xli-2005-02-27/reduce.c
+--- xli-2005-02-27/reduce.c 1999-10-24 22:15:02.000000000 -0400
++++ xli-2005-02-27/reduce.c 2005-10-18 07:33:34.000000000 -0400
+@@ -178,7 +178,7 @@ Image *reduce(Image *image, unsigned col
+ /* get destination image */
+ depth = colorsToDepth(OutColors);
+ new_image = newRGBImage(image->width, image->height, depth);
+- sprintf(buf, "%s (%d colors)", image->title, OutColors);
++ snprintf(buf, sizeof(buf)-1, "%s (%d colors)", image->title, OutColors);
+ new_image->title = dupString(buf);
+ new_image->gamma = image->gamma;
+
+diff -Nrup xli-2005-02-27/rlelib.c xli-2005-02-27/rlelib.c
+--- xli-2005-02-27/rlelib.c 2005-10-18 07:40:51.000000000 -0400
++++ xli-2005-02-27/rlelib.c 2005-10-18 07:48:12.000000000 -0400
+@@ -18,7 +18,7 @@
+ #undef DEBUG
+
+ #ifdef DEBUG
+-# define debug(xx) fprintf(stderr,xx)
++# define debug(xx) fprintf(stderr, "%s", xx)
+ #else
+ # define debug(xx)
+ #endif
+Files xli-2005-02-27/xli and xli-2005-02-27/xli differ
+diff -Nrup xli-2005-02-27/xli.h xli-2005-02-27/xli.h
+--- xli-2005-02-27/xli.h 1999-10-24 22:15:07.000000000 -0400
++++ xli-2005-02-27/xli.h 2005-10-19 07:49:21.000000000 -0400
+@@ -229,7 +229,7 @@ char *xlistrstr(char *s1, char *s2);
+
+ /* path.c */
+ char *expandPath(char *p);
+-int findImage(char *name, char *fullname);
++int findImage(char *name, char *fullname, size_t size);
+ void listImages(void);
+ void loadPathsAndExts(void);
+ void showPath(void);
+diff -Nrup xli-2005-02-27/xlito.c xli-2005-02-27/xlito.c
+--- xli-2005-02-27/xlito.c 2005-02-27 19:42:39.000000000 -0500
++++ xli-2005-02-27/xlito.c 2005-10-18 07:48:54.000000000 -0400
+@@ -31,7 +31,7 @@ char *pname, *fname;
+ #undef DEBUG
+
+ #ifdef DEBUG
+-# define debug(xx) fprintf(stderr,xx)
++# define debug(xx) fprintf(stderr, "%s", xx)
+ #else
+ # define debug(xx)
+ #endif
+diff -Nrup xli-2005-02-27/zoom.c xli-2005-02-27/zoom.c
+--- xli-2005-02-27/zoom.c 2005-02-27 19:42:39.000000000 -0500
++++ xli-2005-02-27/zoom.c 2005-10-18 07:35:42.000000000 -0400
+@@ -52,30 +52,30 @@ Image *zoom(Image *oimage, unsigned int
+ if (verbose)
+ printf(" Zooming image Y axis by %d%%...", yzoom);
+ if (changetitle)
+- sprintf(buf, "%s (Y zoom %d%%)", oimage->title, yzoom);
++ snprintf(buf, sizeof(buf)-1, "%s (Y zoom %d%%)", oimage->title, yzoom);
+ }
+ else if (!yzoom) {
+ if (verbose)
+ printf(" Zooming image X axis by %d%%...", xzoom);
+ if (changetitle)
+- sprintf(buf, "%s (X zoom %d%%)", oimage->title, xzoom);
++ snprintf(buf, sizeof(buf)-1, "%s (X zoom %d%%)", oimage->title, xzoom);
+ }
+ else if (xzoom == yzoom) {
+ if (verbose)
+ printf(" Zooming image by %d%%...", xzoom);
+ if (changetitle)
+- sprintf(buf, "%s (%d%% zoom)", oimage->title, xzoom);
++ snprintf(buf, sizeof(buf)-1, "%s (%d%% zoom)", oimage->title, xzoom);
+ }
+ else {
+ if (verbose)
+ printf(" Zooming image X axis by %d%% and Y axis by %d%%...",
+ xzoom, yzoom);
+ if (changetitle)
+- sprintf(buf, "%s (X zoom %d%% Y zoom %d%%)", oimage->title,
++ snprintf(buf, sizeof(buf)-1, "%s (X zoom %d%% Y zoom %d%%)", oimage->title,
+ xzoom, yzoom);
+ }
+ if (!changetitle)
+- strcpy(buf,oimage->title);
++ strncpy(buf,oimage->title, sizeof(buf)-1);
+
+ if (verbose)
+ fflush(stdout);
diff --git a/media-gfx/xli/metadata.xml b/media-gfx/xli/metadata.xml
new file mode 100644
index 000000000000..9be90a258970
--- /dev/null
+++ b/media-gfx/xli/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/xli/xli-1.17.0-r5.ebuild b/media-gfx/xli/xli-1.17.0-r5.ebuild
new file mode 100644
index 000000000000..1cc713ee8aec
--- /dev/null
+++ b/media-gfx/xli/xli-1.17.0-r5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+SNAPSHOT="2005-02-27"
+DESCRIPTION="X Load Image: view images or load them to root window"
+HOMEPAGE="ftp://ftp.ibiblio.org/pub/Linux/apps/graphics/viewers/X/xli-1.16.README"
+SRC_URI="http://pantransit.reptiles.org/prog/xli/xli-${SNAPSHOT}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="app-arch/bzip2
+ >=media-libs/libpng-1.0.5
+ >=sys-libs/zlib-1.1.4
+ virtual/jpeg:0
+ x11-libs/libXext"
+
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-proto/xextproto
+ x11-misc/imake
+ !media-gfx/xloadimage"
+
+S=${WORKDIR}/${PN}-${SNAPSHOT}
+
+src_prepare() {
+ # avoid conflicts on systems that have zopen in system headers
+ sed -i -e "s:zopen:xli_zopen:g" *
+
+ sed -i Imakefile \
+ -e '/^DEFINES =/s/$/ -DHAVE_GUNZIP -DHAVE_BUNZIP2 /' \
+ -e '/CCOPTIONS =/s/=.*/=/'
+
+ # This is a hack to avoid a parse error on /usr/include/string.h
+ # when _BSD_SOURCE is defined. This may be a bug in that header.
+ sed -i png.c \
+ -e '/^#include "xli.h"/i#undef _BSD_SOURCE'
+
+ # This hack will allow xli to compile using gcc-3.3
+ sed -i rlelib.c \
+ -e 's/#include <varargs.h>//'
+
+ # fix potential security issues.
+ EPATCH_OPTS="-F3 -l" epatch "${FILESDIR}"/xli-security-gentoo.diff
+
+ # Fix scale per bug 282979
+ epatch "${FILESDIR}"/${P}-fix-scale-zoom.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xli xlito
+
+ dosym xli /usr/bin/xsetbg
+ dosym xli /usr/bin/xview
+
+ dodoc README README.xloadimage ABOUTGAMMA TODO chkgamma.jpg
+ newman xli.man xli.1
+ newman xliguide.man xliguide.1
+ newman xlito.man xlito.1
+
+ insinto /etc/X11/app-defaults
+ newins "${FILESDIR}"/Xli.ad Xli
+ fperms a+r /etc/X11/app-defaults/Xli
+}