summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch')
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch b/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
new file mode 100644
index 000000000000..afdea768aa47
--- /dev/null
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
@@ -0,0 +1,23 @@
+diff -ur xloadimage.4.1.orig/Makefile.in xloadimage.4.1/Makefile.in
+--- xloadimage.4.1.orig/Makefile.in 2009-09-04 15:37:09.000000000 +0300
++++ xloadimage.4.1/Makefile.in 2009-09-04 15:38:50.000000000 +0300
+@@ -27,7 +27,7 @@
+ $(CC) -o $@ $(OBJS) build.o $(LDFLAGS) $(XLIB) $(LIBS)
+
+ uufilter: uufilter.c
+- $(CC) $(CFLAGS) $(DEFS) uufilter.c -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) uufilter.c -o $@
+
+ .c.o: config.h image.h
+ $(CC) $(CFLAGS) -c $(DEFS) $<
+diff -ur xloadimage.4.1.orig/uufilter.c xloadimage.4.1/uufilter.c
+--- xloadimage.4.1.orig/uufilter.c 2009-09-04 15:37:09.000000000 +0300
++++ xloadimage.4.1/uufilter.c 2009-09-04 15:37:59.000000000 +0300
+@@ -11,6 +11,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ int main(argc, argv)