summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-14 10:33:33 +0100
committerSam James <sam@gentoo.org>2022-07-14 10:34:05 +0100
commit223c8ca0281987b84f0bccd3cf09a6c7cff9b22c (patch)
tree1174580b94ac6de378854c2fbbade016e865f19d /media-gfx
parentwww-apache/mod_gnutls: drop 0.11.0 (diff)
downloadgentoo-223c8ca0281987b84f0bccd3cf09a6c7cff9b22c.tar.gz
gentoo-223c8ca0281987b84f0bccd3cf09a6c7cff9b22c.tar.bz2
gentoo-223c8ca0281987b84f0bccd3cf09a6c7cff9b22c.zip
media-gfx/ttygif: add 1.6.0
The previous version (1.80_p20181218) was versioned incorrectly, so this is an upgrade. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ttygif/Manifest1
-rw-r--r--media-gfx/ttygif/ttygif-1.6.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/ttygif/Manifest b/media-gfx/ttygif/Manifest
index 1952d7da7f5e..20afe97ec89f 100644
--- a/media-gfx/ttygif/Manifest
+++ b/media-gfx/ttygif/Manifest
@@ -1 +1,2 @@
+DIST ttygif-1.6.0.tar.gz 19288 BLAKE2B cd8a8da6b824f4dc219a9e08bcce7cb1a805d634335fc2bc51b9f79baa96e54ffb4308e4c0924b448ee7a1be53f0391206b3c9eb8705549f41ca7df738cff37f SHA512 3a344d3307a3f2ea96093c39c528452f85c5ee9007a8dd472ad9cd286428753c3b1c11b39c21cf152958e1eee9971798a26bb33374b650b8a7da2f8238c954bf
DIST ttygif-1.80_p20181218.tar.gz 8428 BLAKE2B 376b6dca4d13120b90e3055e8a37acd017aa7966267d6ad76af6eb2cc4155c8b8ce9d618c682cf1c999095c96ae78e11ec343e0752362851f9a2b660820dc403 SHA512 f992094c0baa625106eefdebbde1d91f2686c0b01c4b3ec22ec9339c88df42c830e4417338c685b375646b212db0213983b41b8d6ee9bd9644dfb56f6db31f52
diff --git a/media-gfx/ttygif/ttygif-1.6.0.ebuild b/media-gfx/ttygif/ttygif-1.6.0.ebuild
new file mode 100644
index 000000000000..f1ba96ef0f4f
--- /dev/null
+++ b/media-gfx/ttygif/ttygif-1.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert terminal recordings to animated gifs"
+HOMEPAGE="https://github.com/icholy/ttygif"
+SRC_URI="https://github.com/icholy/ttygif/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( LICENSE README.md )
+
+PATCHES=(
+ "${FILESDIR}/ldflags-support.patch"
+)
+
+RDEPEND="
+ app-misc/ttyrec
+ media-gfx/imagemagick
+ x11-apps/xwd
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DVERSION='\"${PV}\"' -DOS_LINUX" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}