summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Miller <alex.miller@gmx.de>2021-10-04 23:09:21 +0200
committerSam James <sam@gentoo.org>2021-10-06 04:32:27 +0100
commit3565ac667f77439f9a9d751dbf28fdab08c705f0 (patch)
tree25599bda1716cd52ec6f9c2ef40a5bbc79b55d03 /media-gfx
parentmedia-gfx/mandelbulber: Bump to version 2.26 (diff)
downloadgentoo-3565ac667f77439f9a9d751dbf28fdab08c705f0.tar.gz
gentoo-3565ac667f77439f9a9d751dbf28fdab08c705f0.tar.bz2
gentoo-3565ac667f77439f9a9d751dbf28fdab08c705f0.zip
media-gfx/mandelbulber: Add missing openmp check
Signed-off-by: Alexander Miller <alex.miller@gmx.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/mandelbulber/mandelbulber-2.26.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-gfx/mandelbulber/mandelbulber-2.26.ebuild b/media-gfx/mandelbulber/mandelbulber-2.26.ebuild
index 2a64d2e17401..59adb85693f2 100644
--- a/media-gfx/mandelbulber/mandelbulber-2.26.ebuild
+++ b/media-gfx/mandelbulber/mandelbulber-2.26.ebuild
@@ -4,7 +4,7 @@
EAPI=8
MY_P="${PN}2-${PV}"
-inherit desktop qmake-utils xdg-utils
+inherit desktop qmake-utils toolchain-funcs xdg-utils
DESCRIPTION="Tool to render 3D fractals"
HOMEPAGE="https://www.mandelbulber.com"
@@ -46,6 +46,14 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
src_prepare() {
default