summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-11 20:11:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-11 20:39:30 +0200
commit48df0eeabcee288b90be737243212fdc99b420e4 (patch)
tree2f59a9d14f5be55138cc3b58d92dbd62703ac579 /media-gfx
parentdev-python/simsimd: Bump to 5.1.3 (diff)
downloadgentoo-48df0eeabcee288b90be737243212fdc99b420e4.tar.gz
gentoo-48df0eeabcee288b90be737243212fdc99b420e4.tar.bz2
gentoo-48df0eeabcee288b90be737243212fdc99b420e4.zip
media-gfx/fotema: Bump to 1.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotema/Manifest1
-rw-r--r--media-gfx/fotema/fotema-1.14.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotema/Manifest b/media-gfx/fotema/Manifest
index 3174b5f14e0e..825d8b234043 100644
--- a/media-gfx/fotema/Manifest
+++ b/media-gfx/fotema/Manifest
@@ -1 +1,2 @@
DIST fotema-1.14.0.tar.xz 78584796 BLAKE2B c7a53e07fd8ccbd6ba48d595fd280e428ce334908c7b00a4fb5021d92b69c17836ede51656d4a5ab2473fc8220a4b3cbfe25cbdf6da58bc4b7ba7bfbe6ed35dd SHA512 44ff2dd4d3d8268a3f9795f3c37651173a077a7ff831def8e968f658a75786755f7129bed565da674306194084519240b1aa4d378431c36689578f175a054df1
+DIST fotema-1.14.1.tar.xz 78613740 BLAKE2B d945e6be4ef8db99e3c380a75dd6328bcd3a94f885f75bd11db4f164a11f0d541c07d198087aed80a8df637945ca9abc9a98d4c240b0faafe4726d7a82eaef3a SHA512 f80650ccc7401b743e9f6f1b6623f99e5c78df8da44b1608ef1ebfaaf7028858d78a6ca574a712ff2ec1760d4fe0535a365925068be88858eb230ea820803eb2
diff --git a/media-gfx/fotema/fotema-1.14.1.ebuild b/media-gfx/fotema/fotema-1.14.1.ebuild
new file mode 100644
index 000000000000..d4bc59161fe6
--- /dev/null
+++ b/media-gfx/fotema/fotema-1.14.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo gnome2-utils meson xdg-utils
+
+DESCRIPTION="Photo gallery for Linux"
+HOMEPAGE="https://github.com/blissd/fotema"
+SRC_URI="
+ https://github.com/blissd/fotema/releases/download/v${PV}/${P}.tar.xz
+"
+
+# see LICENSES/
+LICENSE="
+ CC-BY-2.0 CC-BY-4.0 CC-BY-NC-SA-4.0 CC-BY-SA-4.0 CC0-1.0
+ FDL-1.3+ GPL-3+ MIT
+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ >=gui-libs/gtk-4.0.0:4
+"
+# indirect deps via crates
+DEPEND+="
+ dev-libs/openssl:=
+ gui-libs/libadwaita
+ media-libs/fontconfig
+ media-libs/graphene
+ media-libs/lcms:2
+ media-libs/libshumate:=
+ media-libs/opencv:=[contribdnn]
+ media-video/ffmpeg:=
+ sci-libs/onnx
+ sys-libs/libseccomp
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+RDEPEND="
+ ${DEPEND}
+ media-libs/glycin-loaders
+"
+BDEPEND="
+ dev-libs/glib:2
+"
+
+ECARGO_VENDOR=${S}/vendor
+
+QA_FLAGS_IGNORED="/usr/bin/fotema"
+
+src_configure() {
+ cat >> "${ECARGO_HOME}/config.toml" <<-EOF || die
+
+ [source."git+https://github.com/blissd/rust-faces.git?branch=patch"]
+ git = "https://github.com/blissd/rust-faces.git"
+ branch = "patch"
+ replace-with = "gentoo"
+ EOF
+
+ local emesonargs=(
+ -Dprofile=$(usex debug development default)
+ )
+
+ meson_src_configure
+ ln -s "${CARGO_HOME}" "${BUILD_DIR}/cargo-home" || die
+
+ export ORT_STRATEGY=system
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}