summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-01 13:06:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-01 17:45:08 +0200
commit72e7e547f32e1fd792e38005d626fee0c162e2d1 (patch)
tree1d666ac33de309018077dfdcfc7ee4d9f445238f /media-gfx
parentmedia-gfx/dmtx-utils: drop 0.7.5 (diff)
downloadgentoo-72e7e547f32e1fd792e38005d626fee0c162e2d1.tar.gz
gentoo-72e7e547f32e1fd792e38005d626fee0c162e2d1.tar.bz2
gentoo-72e7e547f32e1fd792e38005d626fee0c162e2d1.zip
media-gfx/panini: drop 0.73.0-r[01]
Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/37913 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/panini/Manifest1
-rw-r--r--media-gfx/panini/files/panini-0.73.0-drop-register.patch75
-rw-r--r--media-gfx/panini/panini-0.73.0-r1.ebuild56
-rw-r--r--media-gfx/panini/panini-0.73.0.ebuild52
4 files changed, 0 insertions, 184 deletions
diff --git a/media-gfx/panini/Manifest b/media-gfx/panini/Manifest
index 643b50d1467a..84908944f1c3 100644
--- a/media-gfx/panini/Manifest
+++ b/media-gfx/panini/Manifest
@@ -1,2 +1 @@
-DIST panini-0.73.0.tar.gz 329164 BLAKE2B 1cd592d7c5cf230398a6496a27f8389375a670b1de1a0f6acdb2027884bc5059798ad86ad4deb7795402654b3eb9edf112c3c177c7c716d55a186e48e1567f1c SHA512 4c12c0af5f94079f0da8f08dd19d99fd06c16c653b21532eba01022ed5b78afdcea2a042902fd50d0ea442483699cfdf9b10fd7f4592e3bae60abd5d2dabf657
DIST panini-0.74.0.tar.gz 329344 BLAKE2B b94f774004eeb2a1b1531d92ae69141134367c6a87665d3f83944ff38a8761a41813bc023a5ec8e61131a6e193e0bfdc10ccf7100fb0ac518619b9bf94ebeee1 SHA512 e9158040cc985f088902169a2357da1bba5bda5510acec43a8edc95f5cc8033b4f8933f2b5f1b6a651872b467abc4fc3735d1565bae8a8650abd4aa8919f27b7
diff --git a/media-gfx/panini/files/panini-0.73.0-drop-register.patch b/media-gfx/panini/files/panini-0.73.0-drop-register.patch
deleted file mode 100644
index c521c4e6dd5b..000000000000
--- a/media-gfx/panini/files/panini-0.73.0-drop-register.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-https://github.com/lazarus-pkgs/panini/pull/16
-From: Brahmajit Das <brahmajit.xyz@gmail.com>
-Date: Thu, 21 Sep 2023 09:12:45 +0000
-Subject: [PATCH] Fix C++17 does not allow register storage class specifier
-
-C++14 depricated register storage class and it was copletely removed
-from C++17. Hence we get this build error with newer compilers like
-Clang 16 and GCC 14. This patch should fix it.
-
-Bug: https://bugs.gentoo.org/896226
-Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
---- a/src/GLwindow.cpp
-+++ b/src/GLwindow.cpp
-@@ -901,7 +901,7 @@ void GLwindow::setImgAlpha( QImage * pim, double alpha ){
- qint32 m = (int( 255 * alpha ) & 255 ) << 24;
-
- for( int i = pim->width() * pim->height(); i > 0; i-- ){
-- register qint32 t = *pw & 0x00ffffff;
-+ qint32 t = *pw & 0x00ffffff;
- *pw++ = t + m;
- }
- }
-@@ -916,8 +916,8 @@ void GLwindow::diceImgAlpha( QImage * pim, double alpha, int dw ){
- int r = 0, c = 0, w = pim->width();
-
- for( int i = w * pim->height(); i > 0; i-- ){
-- register qint32 t = *pw & 0x00ffffff;
-- register int d = 1;
-+ qint32 t = *pw & 0x00ffffff;
-+ int d = 1;
- if( dw ){ // dice...
- d = ((r + c) / dw) ^ ((r + w - c) / dw);
- }
---- a/src/panocylinder.cpp
-+++ b/src/panocylinder.cpp
-@@ -113,10 +113,10 @@ panocylinder::panocylinder( int divs ){
- double vs = 0.5 * DEG2RAD( 150 ) / double(r2);
-
- for( int r = 0; r < r2; r++){
-- register double t = tan( r * vs );
-- register float * pv = pv0;
-- register float * pu = pv0 + 3 *( cols + r * cols );
-- register float * pl = pv0 - 3 *( cols + r * cols );
-+ double t = tan( r * vs );
-+ float * pv = pv0;
-+ float * pu = pv0 + 3 *( cols + r * cols );
-+ float * pl = pv0 - 3 *( cols + r * cols );
- for( col = 0; col < cols; col++){
- *pu++ = *pv;
- *pl++ = *pv++;
---- a/src/panosphere.cpp
-+++ b/src/panosphere.cpp
-@@ -190,7 +190,7 @@ panosphere::panosphere( int divs ){
- float * ps = verts; // -> front face
-
- for( int i = 0; i < ppf; i++ ){
-- register float * p = ps;
-+ float * p = ps;
-
- p += jf; // ->top
- p[0] = ps[0]; // x = x
---- a/src/pvQtView.cpp
-+++ b/src/pvQtView.cpp
-@@ -465,7 +465,7 @@ void pvQtView::clipEyePosition(){
- x = c * sin(azi),
- y = sin(alt),
- z = c * cos(azi);
-- register double s = eyeDistance;
-+ double s = eyeDistance;
- // the cube texture is only 1 radius wide
- if( picType == pvQtPic::cub ) s *= 0.5;
- eyex = x * s;
---
-2.42.0
-
diff --git a/media-gfx/panini/panini-0.73.0-r1.ebuild b/media-gfx/panini/panini-0.73.0-r1.ebuild
deleted file mode 100644
index 2edaa0d3c56e..000000000000
--- a/media-gfx/panini/panini-0.73.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop qmake-utils xdg-utils
-
-MY_P="${P/p/P}-src"
-DESCRIPTION="OpenGL-based panoramic image viewer"
-HOMEPAGE="https://github.com/lazarus-pkgs/panini"
-SRC_URI="https://github.com/lazarus-pkgs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
- sys-libs/zlib
- virtual/glu
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
-"
-
-DOCS=( NEWS {BUILD,README,USAGE}.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.73.0-drop-register.patch
-)
-
-src_prepare() {
- default
- eqmake5 ${PN}.pro
-}
-
-src_install() {
- einstalldocs
- dobin panini
- domenu "${FILESDIR}"/${PN}.desktop
- newicon ui/panini-icon-blue.jpg ${PN}.jpg
-}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
diff --git a/media-gfx/panini/panini-0.73.0.ebuild b/media-gfx/panini/panini-0.73.0.ebuild
deleted file mode 100644
index 32106c228518..000000000000
--- a/media-gfx/panini/panini-0.73.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop qmake-utils xdg-utils
-
-MY_P="${P/p/P}-src"
-DESCRIPTION="OpenGL-based panoramic image viewer"
-HOMEPAGE="https://github.com/lazarus-pkgs/panini"
-SRC_URI="https://github.com/lazarus-pkgs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
- sys-libs/zlib
- virtual/glu
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
-"
-
-DOCS=( NEWS {BUILD,README,USAGE}.md )
-
-src_prepare() {
- default
- eqmake5 ${PN}.pro
-}
-
-src_install() {
- einstalldocs
- dobin panini
- domenu "${FILESDIR}"/${PN}.desktop
- newicon ui/panini-icon-blue.jpg ${PN}.jpg
-}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}