summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-21 23:46:58 +0000
committerSam James <sam@gentoo.org>2022-12-21 23:52:00 +0000
commit1b67509015dbe51f15a0c7d3f4c316826dc927de (patch)
tree06b1e483427bc7513f616bf6f3ac96cbcd399f5e /media-libs/gegl
parentdev-util/glib-utils: add 2.74.4 (diff)
downloadgentoo-1b67509015dbe51f15a0c7d3f4c316826dc927de.tar.gz
gentoo-1b67509015dbe51f15a0c7d3f4c316826dc927de.tar.bz2
gentoo-1b67509015dbe51f15a0c7d3f4c316826dc927de.zip
media-libs/gegl: fix -Wstrict-prototypes
Signed-off-by: Carlos Eduardo <carana2099@gmail.com> Closes: https://bugs.gentoo.org/883313 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/files/gegl-0.4.40-strict-prototypes.patch79
-rw-r--r--media-libs/gegl/gegl-0.4.40-r1.ebuild4
2 files changed, 83 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.4.40-strict-prototypes.patch b/media-libs/gegl/files/gegl-0.4.40-strict-prototypes.patch
new file mode 100644
index 000000000000..6982afa4d7b0
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.4.40-strict-prototypes.patch
@@ -0,0 +1,79 @@
+https://bugs.gentoo.org/883313
+https://gitlab.gnome.org/GNOME/gegl/-/merge_requests/132
+--- a/gegl/graph/gegl-region-generic.c
++++ b/gegl/graph/gegl-region-generic.c
+@@ -910,7 +910,7 @@ miRegionOp (GeglRegion *newReg,
+ top = MAX (r1->y1, ybot);
+ bot = MIN (r1->y2, r2->y1);
+
+- if ((top != bot) && (nonOverlap1Fn != (void (*)())NULL))
++ if ((top != bot) && (nonOverlap1Fn != (void (*)(void))NULL))
+ {
+ (*nonOverlap1Fn)(newReg, r1, r1BandEnd, top, bot);
+ }
+@@ -922,7 +922,7 @@ miRegionOp (GeglRegion *newReg,
+ top = MAX (r2->y1, ybot);
+ bot = MIN (r2->y2, r1->y1);
+
+- if ((top != bot) && (nonOverlap2Fn != (void (*)())NULL))
++ if ((top != bot) && (nonOverlap2Fn != (void (*)(void))NULL))
+ {
+ (*nonOverlap2Fn)(newReg, r2, r2BandEnd, top, bot);
+ }
+--- a/operations/common/ctx/ctx.h
++++ b/operations/common/ctx/ctx.h
+@@ -6047,7 +6047,6 @@ int _ctx_is_rasterizer (Ctx *ctx);
+
+ int ctx_color (Ctx *ctx, const char *string);
+ typedef struct _CtxState CtxState;
+-CtxColor *ctx_color_new ();
+ CtxState *ctx_get_state (Ctx *ctx);
+ void ctx_color_get_rgba (CtxState *state, CtxColor *color, float *out);
+ void ctx_color_set_rgba (CtxState *state, CtxColor *color, float r, float g, float b, float a);
+@@ -11081,7 +11080,6 @@ static void
+ ctx_matrix_set (CtxMatrix *matrix, float a, float b, float c, float d, float e, float f, float g, float h, float i);
+
+
+-static void ctx_font_setup ();
+ static float ctx_state_get (CtxState *state, uint32_t hash);
+
+ #if CTX_RASTERIZER
+@@ -40708,9 +40706,9 @@ static void ctx_events_deinit (Ctx *ctx)
+ #if CTX_TERMINAL_EVENTS
+
+
+-static int mice_has_event ();
+-static char *mice_get_event ();
+-static void mice_destroy ();
++static int mice_has_event (void);
++static char *mice_get_event (void);
++static void mice_destroy (void);
+ static int mice_get_fd (EvSource *ev_source);
+ static void mice_set_coord (EvSource *ev_source, double x, double y);
+
+@@ -40759,13 +40757,13 @@ static int mmm_evsource_mice_init ()
+ return 0;
+ }
+
+-static void mice_destroy ()
++static void mice_destroy (void)
+ {
+ if (mrg_mice_this->fd != -1)
+ close (mrg_mice_this->fd);
+ }
+
+-static int mice_has_event ()
++static int mice_has_event (void)
+ {
+ struct timeval tv;
+ int retval;
+@@ -40783,7 +40781,7 @@ static int mice_has_event ()
+ return 0;
+ }
+
+-static char *mice_get_event ()
++static char *mice_get_event (void)
+ {
+ const char *ret = "pm";
+ double relx, rely;
+
diff --git a/media-libs/gegl/gegl-0.4.40-r1.ebuild b/media-libs/gegl/gegl-0.4.40-r1.ebuild
index a99b95054c29..bcb10baa5cb6 100644
--- a/media-libs/gegl/gegl-0.4.40-r1.ebuild
+++ b/media-libs/gegl/gegl-0.4.40-r1.ebuild
@@ -76,6 +76,10 @@ BDEPEND="
DOCS=( AUTHORS docs/ChangeLog docs/NEWS.adoc )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.40-strict-prototypes.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}