summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2024-04-29 10:04:12 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-05-04 21:57:05 +0100
commite3c7ba0527e7a5be8f6d590212cbc77d922bc203 (patch)
treef0694bfc4b4a32635a043c3991530ae3ee3561b7 /media-libs/glfw
parentx11-misc/qps: add LXQt project as a maintainer (diff)
downloadgentoo-e3c7ba0527e7a5be8f6d590212cbc77d922bc203.tar.gz
gentoo-e3c7ba0527e7a5be8f6d590212cbc77d922bc203.tar.bz2
gentoo-e3c7ba0527e7a5be8f6d590212cbc77d922bc203.zip
media-libs/glfw: add 3.4
changed USE=wayland-only to USE=wayland, adding also USE=X. the cmake flag for wayland support has been renamed upstream. i am not sure if building with support for both modes is meaningful. Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36475 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/glfw')
-rw-r--r--media-libs/glfw/Manifest1
-rw-r--r--media-libs/glfw/glfw-3.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
index 7d15d29c35b9..00e7bbeb8f08 100644
--- a/media-libs/glfw/Manifest
+++ b/media-libs/glfw/Manifest
@@ -1,2 +1,3 @@
DIST glfw-3.3.8.tar.gz 803789 BLAKE2B e06b319f4b5c1aaa27b32895c39fb1759adc0576a1e4c3fef095b31f204709d7ec6a89a915604b39daaa9f481a2bf2dbff165948ab2074b8a0b12c2afe913c0e SHA512 70d6d99fb7e7616990516070c9a430915dc68d89ec4fe785570f0b35f5c9606a34121e0cd57c0a7debb50e87e2a8e8d97d81a6d52d65ef454f7fd191bd9f679f
DIST glfw-3.3.9.tar.gz 819671 BLAKE2B be0195c27653880e4d75f801b59838f31dbc8c42883e884ee76743883066fd028a8752d0e12cd9918bbd993750e673fec02e779fb559d3eaa0bc9ba40aeee049 SHA512 9fcccd650990fa88fcb6383afa90bc6c2eca7f4a4a3d4fc58fa5bd6b7995c32989bb29d2753f438984043b294244b82ba9f094426e12f3d4da4547e73bb62e3f
+DIST glfw-3.4.tar.gz 936948 BLAKE2B f8f93e15d96ffc3f5c49bef7336ac49ae5ed3d1d12f405d152e1d37cda0d2091f025812c99d617210690d2b1fbf3fda6b6d50d3569b81fcd54944a63afd258ab SHA512 39ad7a4521267fbebc35d2ff0c389a56236ead5fa4bdff33db113bd302f70f5f2869ff4e6db1979512e1542813292dff5a482e94dfce231750f0746c301ae9ed
diff --git a/media-libs/glfw/glfw-3.4.ebuild b/media-libs/glfw/glfw-3.4.ebuild
new file mode 100644
index 000000000000..ca054b61adad
--- /dev/null
+++ b/media-libs/glfw/glfw-3.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+RDEPEND="
+ media-libs/libglvnd[${MULTILIB_USEDEP}]
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+ X? (
+ media-libs/libglvnd[X]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ )"
+DEPEND="
+ ${RDEPEND}
+ wayland? (
+ dev-libs/wayland-protocols
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXinerama[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ )"
+BDEPEND="
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_BUILD_WAYLAND=$(usex wayland)
+ -DGLFW_BUILD_X11=$(usex X)
+ )
+
+ cmake-multilib_src_configure
+}