summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-27 00:50:36 +0000
committerSam James <sam@gentoo.org>2022-02-27 00:50:36 +0000
commit1c96a698995a0d7536206b2f0d78358330c82254 (patch)
treee7f0f88003d680a3177d1e771fc6eb7e983184e5 /media-libs/glyr/glyr-1.0.10-r1.ebuild
parentsys-apps/sensei-raw-ctl: update EAPI 6 -> 8 (diff)
downloadgentoo-1c96a698995a0d7536206b2f0d78358330c82254.tar.gz
gentoo-1c96a698995a0d7536206b2f0d78358330c82254.tar.bz2
gentoo-1c96a698995a0d7536206b2f0d78358330c82254.zip
media-libs/glyr: update EAPI 6 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/glyr/glyr-1.0.10-r1.ebuild')
-rw-r--r--media-libs/glyr/glyr-1.0.10-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/glyr/glyr-1.0.10-r1.ebuild b/media-libs/glyr/glyr-1.0.10-r1.ebuild
new file mode 100644
index 000000000000..0d8bc15b0992
--- /dev/null
+++ b/media-libs/glyr/glyr-1.0.10-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Music related metadata searchengine, both with commandline interface and C API"
+HOMEPAGE="https://github.com/sahib/glyr"
+SRC_URI="https://github.com/sahib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.10:2
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS README.textile ) # CHANGELOG is obsolete in favour of git history
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-version.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i \
+ -e '/GCC_ONLY_OPT.*-s/d' \
+ -e '/FLAGS/s:-Os::' \
+ -e '/FLAGS/s:-g3::' \
+ CMakeLists.txt || die
+}