summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-11 23:14:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-11 23:15:38 +0200
commitd2967bda08f95b88927a49db056343ead3ef735f (patch)
tree85631a5b463830353d54bcd8917f1888805d10c9 /media-libs/libmatroska/libmatroska-1.6.2.ebuild
parentdev-python/awscli: 1.18.117 bump; relax rsa dependency. (diff)
downloadgentoo-d2967bda08f95b88927a49db056343ead3ef735f.tar.gz
gentoo-d2967bda08f95b88927a49db056343ead3ef735f.tar.bz2
gentoo-d2967bda08f95b88927a49db056343ead3ef735f.zip
media-libs/libmatroska: bump to v1.6.2
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/libmatroska/libmatroska-1.6.2.ebuild')
-rw-r--r--media-libs/libmatroska/libmatroska-1.6.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/libmatroska/libmatroska-1.6.2.ebuild b/media-libs/libmatroska/libmatroska-1.6.2.ebuild
new file mode 100644
index 000000000000..b11f8b3bc3d1
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-1.6.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libmatroska/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/7" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/libebml-1.4.0:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
+ cmake_src_configure
+}