summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-02-23 00:16:27 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-05-20 22:02:08 +0100
commit8fc630eb6356c8c2a9ebafdb5ee7a1d6dba2cdf7 (patch)
treeee16de67c9ba27adcd26237ff236254272c5e34f /media-libs/libsdl2
parentdev-qt/qtwebengine: dev-util/gn required on ppc64 (diff)
downloadgentoo-8fc630eb6356c8c2a9ebafdb5ee7a1d6dba2cdf7.tar.gz
gentoo-8fc630eb6356c8c2a9ebafdb5ee7a1d6dba2cdf7.tar.bz2
gentoo-8fc630eb6356c8c2a9ebafdb5ee7a1d6dba2cdf7.zip
media-libs/libsdl2: Add sndio support
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/19609 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.14-r2.ebuild6
-rw-r--r--media-libs/libsdl2/metadata.xml1
2 files changed, 5 insertions, 2 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.14-r2.ebuild b/media-libs/libsdl2/libsdl2-2.0.14-r2.ebuild
index e6a22bd2b6b1..50f6d8e1fe46 100644
--- a/media-libs/libsdl2/libsdl2-2.0.14-r2.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.14-r2.ebuild
@@ -14,7 +14,7 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pulseaudio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( sound )
fcitx4? ( dbus )
@@ -25,6 +25,7 @@ REQUIRED_USE="
nas? ( sound )
opengl? ( video )
pulseaudio? ( sound )
+ sndio? ( sound )
vulkan? ( video )
wayland? ( gles2 )
xinerama? ( X )
@@ -52,6 +53,7 @@ CDEPEND="
>=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
)
pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ sndio? ( media-sound/sndio:=[${MULTILIB_USEDEP}] )
udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
wayland? (
>=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}]
@@ -154,7 +156,7 @@ multilib_src_configure() {
$(use_enable libsamplerate)
$(use_enable nas)
--disable-nas-shared
- --disable-sndio
+ $(use_enable sndio)
--disable-sndio-shared
$(use_enable sound diskaudio)
$(use_enable sound dummyaudio)
diff --git a/media-libs/libsdl2/metadata.xml b/media-libs/libsdl2/metadata.xml
index a35fb97837a8..7c587dc6d2ec 100644
--- a/media-libs/libsdl2/metadata.xml
+++ b/media-libs/libsdl2/metadata.xml
@@ -31,6 +31,7 @@
<flag name="ibus">Enable support for <pkg>app-i18n/ibus</pkg></flag>
<flag name="joystick">Control joystick support (disable at your own risk)</flag>
<flag name="kms">Build the KMSDRM video driver</flag>
+ <flag name="sndio">Enable support for the <pkg>media-sound/sndio</pkg> backend</flag>
<flag name="sound">Control audio support (disable at your own risk)</flag>
<flag name="tslib">Build with tslib support for touchscreen devices</flag>
<flag name="video">Control video support (disable at your own risk)</flag>