summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libtimidity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libtimidity')
-rw-r--r--media-libs/libtimidity/Manifest1
-rw-r--r--media-libs/libtimidity/files/libtimidity-0.1.0-automagic.patch30
-rw-r--r--media-libs/libtimidity/files/libtimidity-0.1.0-newlen-overflow.patch22
-rw-r--r--media-libs/libtimidity/libtimidity-0.1.0-r2.ebuild35
-rw-r--r--media-libs/libtimidity/metadata.xml8
5 files changed, 96 insertions, 0 deletions
diff --git a/media-libs/libtimidity/Manifest b/media-libs/libtimidity/Manifest
new file mode 100644
index 000000000000..a1b3ba919bed
--- /dev/null
+++ b/media-libs/libtimidity/Manifest
@@ -0,0 +1 @@
+DIST libtimidity-0.1.0.tar.bz2 273410 SHA256 52c6de6608ba640b4678041c01320290790a1f18c901ef03575fbf47807350bf SHA512 7401e9b85c7e93c17871a9d767dfa9434808bf90d7d693522862c5f534f56dcac6c39fe24fc38b097505df349dad9f57e7ea2c6ae2deb9adce7d2ec861184ed1 WHIRLPOOL 380075ba9b84a14f7ad36a7f974d74d94a221f375c2d59bf3afcfa4fb616f01945f1c9c8d0a940763d558243d9213b252850b81003b00174e31a47ea0b35e4f6
diff --git a/media-libs/libtimidity/files/libtimidity-0.1.0-automagic.patch b/media-libs/libtimidity/files/libtimidity-0.1.0-automagic.patch
new file mode 100644
index 000000000000..ead93ffd32dd
--- /dev/null
+++ b/media-libs/libtimidity/files/libtimidity-0.1.0-automagic.patch
@@ -0,0 +1,30 @@
+diff -ur libtimidity-0.1.0.orig/configure.ac libtimidity-0.1.0/configure.ac
+--- libtimidity-0.1.0.orig/configure.ac 2004-11-23 06:30:46.000000000 +0200
++++ libtimidity-0.1.0/configure.ac 2007-08-02 15:51:47.000000000 +0300
+@@ -39,9 +39,24 @@
+ # Checks for libraries.
+ LIBTIMIDITY_LIBS=""
+ AC_CHECK_LIB([m], [pow], [LIBTIMIDITY_LIBS="$TIMIDITY_LIBS -lm"])
+-have_ao=no
+-XIPH_PATH_AO([have_ao=yes])
++
++AC_ARG_ENABLE([ao],
++ [AS_HELP_STRING([--enable-ao], [Enable libao (default=disabled)])],
++ [have_ao="$enableval"],
++ [have_ao="no"]
++)
++
++if test "$have_ao" = "yes"; then
++ PKG_CHECK_MODULES([AO], [ao >= 0.8.5])
++ AC_DEFINE([AO], [], [Define when building with ao])
++ HAVE_AO="true"
++else
++ HAVE_AO="false"
++fi
++
++AC_SUBST([ENABLE_AO])
+ AM_CONDITIONAL([HAVE_AO], [test $have_ao = yes])
++AC_SUBST(AO_LIBS)
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/media-libs/libtimidity/files/libtimidity-0.1.0-newlen-overflow.patch b/media-libs/libtimidity/files/libtimidity-0.1.0-newlen-overflow.patch
new file mode 100644
index 000000000000..22952a5ebba1
--- /dev/null
+++ b/media-libs/libtimidity/files/libtimidity-0.1.0-newlen-overflow.patch
@@ -0,0 +1,22 @@
+diff -Naur libtimidity-0.1.0/src/resample.c libtimidity-0.1.0-r1/src/resample.c
+--- libtimidity-0.1.0/src/resample.c 2004-11-21 23:02:53.000000000 +0100
++++ libtimidity-0.1.0-r1/src/resample.c 2008-02-24 18:46:36.000000000 +0100
+@@ -545,7 +545,8 @@
+ void pre_resample(MidSong *song, MidSample *sp)
+ {
+ double a, xdiff;
+- sint32 incr, ofs, newlen, count;
++ sint32 incr, ofs, count;
++ unsigned int newlen;
+ sint16 *newdata, *dest, *src = (sint16 *) sp->data;
+ sint16 v1, v2, v3, v4, *vptr;
+ #ifdef DEBUG_CHATTER
+@@ -561,7 +562,7 @@
+
+ a = ((double) (sp->sample_rate) * freq_table[(int) (sp->note_to_use)]) /
+ ((double) (sp->root_freq) * song->rate);
+- newlen = (sint32)(sp->data_length / a);
++ newlen = (unsigned int)(sp->data_length / a);
+ dest = newdata = safe_malloc(newlen >> (FRACTION_BITS - 1));
+
+ count = (newlen >> FRACTION_BITS) - 1;
diff --git a/media-libs/libtimidity/libtimidity-0.1.0-r2.ebuild b/media-libs/libtimidity/libtimidity-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..c3ad5d9d9e39
--- /dev/null
+++ b/media-libs/libtimidity/libtimidity-0.1.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="MIDI to WAVE converter library"
+HOMEPAGE="http://libtimidity.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE="ao debug"
+
+RDEPEND="ao? ( >=media-libs/libao-1.1.0-r2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
+DOCS="AUTHORS ChangeLog CHANGES NEWS TODO README*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-newlen-overflow.patch \
+ "${FILESDIR}"/${P}-automagic.patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(use_enable ao) \
+ $(use_enable debug)
+}
diff --git a/media-libs/libtimidity/metadata.xml b/media-libs/libtimidity/metadata.xml
new file mode 100644
index 000000000000..9ec4f8c12dbb
--- /dev/null
+++ b/media-libs/libtimidity/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">libtimidity</remote-id>
+ </upstream>
+</pkgmetadata>