summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2015-08-18 13:39:42 +0200
committerAmy Winston <amynka@gentoo.org>2015-08-18 14:13:28 +0200
commitc030d441200f3ed0c35ea730c3cae7af68f68ced (patch)
tree8440299a02ba32ad78b1aeb39d60849e46a0b6a3 /media-libs/opencv/opencv-3.0.0.ebuild
parentmedia-sound/banshee: Restrict to mono 3 support (diff)
downloadgentoo-c030d441200f3ed0c35ea730c3cae7af68f68ced.tar.gz
gentoo-c030d441200f3ed0c35ea730c3cae7af68f68ced.tar.bz2
gentoo-c030d441200f3ed0c35ea730c3cae7af68f68ced.zip
media-libs/opencv: contrib useflag added bug #557870.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/opencv/opencv-3.0.0.ebuild')
-rw-r--r--media-libs/opencv/opencv-3.0.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/opencv/opencv-3.0.0.ebuild b/media-libs/opencv/opencv-3.0.0.ebuild
index 5f5616762991..a528d739b9bb 100644
--- a/media-libs/opencv/opencv-3.0.0.ebuild
+++ b/media-libs/opencv/opencv-3.0.0.ebuild
@@ -12,12 +12,13 @@ HOMEPAGE="http://opencv.org"
SRC_URI="
mirror://sourceforge/opencvlibrary/opencv-unix/${PV}/${P}.zip
- https://github.com/Itseez/${PN}/archive/${PV}.zip -> ${P}.zip"
+ https://github.com/Itseez/${PN}/archive/${PV}.zip -> ${P}.zip
+ contrib? ( https://github.com/Itseez/${PN}_contrib/archive/master.zip -> ${PN}_contrib.zip )"
LICENSE="BSD"
SLOT="0/3.0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="cuda doc +eigen examples ffmpeg gstreamer gtk ieee1394 ipp jpeg jpeg2k libav opencl openexr opengl openmp pch png +python qt4 qt5 testprograms threads tiff v4l vtk xine"
+IUSE="contrib cuda doc +eigen examples ffmpeg gstreamer gtk ieee1394 ipp jpeg jpeg2k libav opencl openexr opengl openmp pch png +python qt4 qt5 testprograms threads tiff v4l vtk xine"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
qt4? ( !qt5 )
@@ -173,6 +174,10 @@ src_configure() {
mycmakeargs+=( "-DWITH_QT=OFF" )
fi
+ if use contrib; then
+ mycmakeargs+=( "-DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-master/modules" )
+ fi
+
if use cuda; then
if [[ "$(gcc-version)" > "4.7" ]]; then
ewarn "CUDA and >=sys-devel/gcc-4.8 do not play well together. Disabling CUDA support."