summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-31 08:52:33 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-31 08:56:16 -0400
commit151efa9ce95c2c7ae9583c30cb9785ac568d6d76 (patch)
treec15818fbc2b39c21135520bb38c3644005d25c25 /media-libs/opus/opus-1.2.1.ebuild
parentmedia-libs/opus: move from git-2 to git-r3 and use https for git repo (diff)
downloadgentoo-151efa9ce95c2c7ae9583c30cb9785ac568d6d76.tar.gz
gentoo-151efa9ce95c2c7ae9583c30cb9785ac568d6d76.tar.bz2
gentoo-151efa9ce95c2c7ae9583c30cb9785ac568d6d76.zip
media-libs/opus: use upstream provided release tarball for 1.2.1
Diffstat (limited to 'media-libs/opus/opus-1.2.1.ebuild')
-rw-r--r--media-libs/opus/opus-1.2.1.ebuild16
1 files changed, 2 insertions, 14 deletions
diff --git a/media-libs/opus/opus-1.2.1.ebuild b/media-libs/opus/opus-1.2.1.ebuild
index ea49b691cc38..5df700cc6555 100644
--- a/media-libs/opus/opus-1.2.1.ebuild
+++ b/media-libs/opus/opus-1.2.1.ebuild
@@ -2,13 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools multilib-minimal
+inherit multilib-minimal
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.xiph.org/opus.git"
else
- SRC_URI="https://github.com/xiph/opus/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://archive.mozilla.org/pub/opus/${P}.tar.gz"
if [[ "${PV}" != *_alpha* ]] && [[ "${PV}" != *_beta* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
@@ -24,18 +24,6 @@ IUSE="ambisonics custom-modes doc static-libs ${INTRINSIC_FLAGS}"
DEPEND="doc? ( app-doc/doxygen media-gfx/graphviz )"
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- default
-
- if [[ ! -f package_version ]] ; then
- echo "PACKAGE_VERSION=\"${PV/_/-}\"" > package_version
- fi
-
- eautoreconf
-}
-
multilib_src_configure() {
local myeconfargs=(
$(use_enable ambisonics)