summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-09 19:49:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-09 19:54:12 +0100
commit8a6d0f53c0cb347e8ed56aee90f5ff5d4b1e95f7 (patch)
treeb2e6d596bd619b06122c7dad26b9be3b8fbdf882 /media-libs
parentdev-libs/beecrypt: Drop 4.2.1-r4 (diff)
downloadgentoo-8a6d0f53c0cb347e8ed56aee90f5ff5d4b1e95f7.tar.gz
gentoo-8a6d0f53c0cb347e8ed56aee90f5ff5d4b1e95f7.tar.bz2
gentoo-8a6d0f53c0cb347e8ed56aee90f5ff5d4b1e95f7.zip
media-libs/libextractor: Drop 1.6
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libextractor/Manifest1
-rw-r--r--media-libs/libextractor/files/libextractor-1.6-CVE-2017-17440.patch125
-rw-r--r--media-libs/libextractor/files/libextractor-1.6-ffmpeg-4.patch20
-rw-r--r--media-libs/libextractor/libextractor-1.6.ebuild119
4 files changed, 0 insertions, 265 deletions
diff --git a/media-libs/libextractor/Manifest b/media-libs/libextractor/Manifest
index 30c0448cfce4..2b3e4e92b8ba 100644
--- a/media-libs/libextractor/Manifest
+++ b/media-libs/libextractor/Manifest
@@ -1,2 +1 @@
-DIST libextractor-1.6.tar.gz 8053454 BLAKE2B cf5e9d5fd1bc09e20495810e5a85280916632eb1c5e5c6c68aaf1cbccb8a5970465d3fd6b313e0cfc7e5c262a815996d7bec563c04b04faf7467ddbe987dfb4c SHA512 1e477450d89cc83030100fc9dc11734f39b1ccd1765f8cf4a4938f32253e2e19a48b5337328605451589865142b2d6bf6d7102198115985a1e0da22fca4bc2a8
DIST libextractor-1.7.tar.gz 8075299 BLAKE2B ce738f8839dded4065f8f8d4241c8ad525930f852492605af75c7031b5204c09763c2d4c7a84df6e062512e66509fa308163bcbfd5b655e071c8e43d4fe48f07 SHA512 00340af0987f58c16824f50a18484e76f110fa2b4a43788b950ea4313e6916b94d5e7f16e1f21c8a54509885d9b44dabdc5be7727547549836ddd8ca7251dbff
diff --git a/media-libs/libextractor/files/libextractor-1.6-CVE-2017-17440.patch b/media-libs/libextractor/files/libextractor-1.6-CVE-2017-17440.patch
deleted file mode 100644
index 1870375664de..000000000000
--- a/media-libs/libextractor/files/libextractor-1.6-CVE-2017-17440.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-From 7cc63b001ceaf81143795321379c835486d0c92e Mon Sep 17 00:00:00 2001
-From: Christian Grothoff <christian@grothoff.org>
-Date: Wed, 1 Nov 2017 09:07:35 +0100
-Subject: fix misc NULL pointer exceptions
-
----
- src/include/extractor.h | 2 +-
- src/plugins/gif_extractor.c | 16 +++++++++-------
- src/plugins/it_extractor.c | 6 +++---
- src/plugins/nsfe_extractor.c | 8 ++++----
- src/plugins/s3m_extractor.c | 2 +-
- src/plugins/sid_extractor.c | 24 ++++++++++++------------
- src/plugins/xm_extractor.c | 8 ++++----
- 21 files changed, 169 insertions(+), 162 deletions(-)
-
-* asturm: Cleaned up unrelated whitespace and translations changes.
-
-diff --git a/src/include/extractor.h b/src/include/extractor.h
-index 0325dc6..782134b 100644
---- a/src/include/extractor.h
-+++ b/src/include/extractor.h
-@@ -35,7 +35,7 @@ extern "C" {
- * 0.2.6-1 => 0x00020601
- * 4.5.2-0 => 0x04050200
- */
--#define EXTRACTOR_VERSION 0x01060000
-+#define EXTRACTOR_VERSION 0x01060001
-
- #include <stdio.h>
-
-diff --git a/src/plugins/gif_extractor.c b/src/plugins/gif_extractor.c
-index aae2b82..8ee5807 100644
-@@ -122,6 +122,8 @@ EXTRACTOR_gif_extract_method (struct EXTRACTOR_ExtractContext *ec)
- if (GIF_OK !=
- DGifGetExtension (gif_file, &et, &ext))
- continue;
-+ if (NULL == ext)
-+ continue;
- if (COMMENT_EXT_FUNC_CODE == et)
- {
- ec->proc (ec->cls,
---- a/src/plugins/it_extractor.c
-+++ b/src/plugins/it_extractor.c
-@@ -70,7 +70,7 @@ EXTRACTOR_it_extract_method (struct EXTRACTOR_ExtractContext *ec)
- char itversion[8];
- const struct Header *head;
-
-- if (HEADER_SIZE >
-+ if ((ssize_t) HEADER_SIZE >
- ec->read (ec->cls,
- &data,
- HEADER_SIZE))
---- a/src/plugins/nsfe_extractor.c
-+++ b/src/plugins/nsfe_extractor.c
-@@ -175,7 +175,7 @@ info_extract (struct EXTRACTOR_ExtractContext *ec,
-
- if (size < 8)
- return 0;
-- if (size >
-+ if ((ssize_t) size >
- ec->read (ec->cls,
- &data,
- size))
-@@ -243,7 +243,7 @@ tlbl_extract (struct EXTRACTOR_ExtractContext *ec,
- void *data;
- const char *cdata;
-
-- if (size >
-+ if ((ssize_t) size >
- ec->read (ec->cls,
- &data,
- size))
-@@ -285,7 +285,7 @@ auth_extract (struct EXTRACTOR_ExtractContext *ec,
-
- if (left < 1)
- return 0;
-- if (size >
-+ if ((ssize_t) size >
- ec->read (ec->cls,
- &data,
- size))
-@@ -342,7 +342,7 @@ EXTRACTOR_nsfe_extract_method (struct EXTRACTOR_ExtractContext *ec)
- uint32_t chunksize;
- int ret;
-
-- if (sizeof (struct header) >
-+ if ((ssize_t) sizeof (struct header) >
- ec->read (ec->cls,
- &data,
- sizeof (struct header)))
---- a/src/plugins/s3m_extractor.c
-+++ b/src/plugins/s3m_extractor.c
-@@ -80,7 +80,7 @@ EXTRACTOR_s3m_extract_method (struct EXTRACTOR_ExtractContext *ec)
- struct S3MHeader header;
- char song_name_NT[29];
-
-- if (sizeof (header) >
-+ if ((ssize_t) sizeof (header) >
- ec->read (ec->cls,
- &data,
- sizeof (header)))
---- a/src/plugins/sid_extractor.c
-+++ b/src/plugins/sid_extractor.c
-@@ -176,7 +176,7 @@ EXTRACTOR_sid_extract_method (struct EXTRACTOR_ExtractContext *ec)
- const struct header *head;
- void *data;
-
-- if (sizeof (struct header) >
-+ if ((ssize_t) sizeof (struct header) >
- ec->read (ec->cls,
- &data,
- sizeof (struct header)))
---- a/src/plugins/xm_extractor.c
-+++ b/src/plugins/xm_extractor.c
-@@ -70,7 +70,7 @@ EXTRACTOR_xm_extract_method (struct EXTRACTOR_ExtractContext *ec)
- char xmversion[8];
- size_t n;
-
-- if (sizeof (struct Header) >
-+ if ((ssize_t) sizeof (struct Header) >
- ec->read (ec->cls,
- &data,
- sizeof (struct Header)))
---
-cgit v1.1
diff --git a/media-libs/libextractor/files/libextractor-1.6-ffmpeg-4.patch b/media-libs/libextractor/files/libextractor-1.6-ffmpeg-4.patch
deleted file mode 100644
index 90360afd60a5..000000000000
--- a/media-libs/libextractor/files/libextractor-1.6-ffmpeg-4.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/plugins/thumbnailffmpeg_extractor.c 2018-05-09 23:14:02.721105141 +0200
-+++ b/src/plugins/thumbnailffmpeg_extractor.c 2018-05-09 23:14:48.491629162 +0200
-@@ -107,7 +107,7 @@
- /**
- * Number of bytes to feed to libav in one go, with padding (padding is zeroed).
- */
--#define PADDED_BUFFER_SIZE (BUFFER_SIZE + FF_INPUT_BUFFER_PADDING_SIZE)
-+#define PADDED_BUFFER_SIZE (BUFFER_SIZE + AV_INPUT_BUFFER_PADDING_SIZE)
-
- /**
- * Global handle to MAGIC data.
-@@ -355,7 +355,7 @@
- encoder_codec_ctx->mb_lmin = encoder_codec_ctx->qmin * FF_QP2LAMBDA;
- encoder_codec_ctx->mb_lmax = encoder_codec_ctx->qmax * FF_QP2LAMBDA;
- #endif
-- encoder_codec_ctx->flags = CODEC_FLAG_QSCALE;
-+ encoder_codec_ctx->flags = AV_CODEC_FLAG_QSCALE;
- encoder_codec_ctx->global_quality = encoder_codec_ctx->qmin * FF_QP2LAMBDA;
-
- dst_frame->pts = 1;
diff --git a/media-libs/libextractor/libextractor-1.6.ebuild b/media-libs/libextractor/libextractor-1.6.ebuild
deleted file mode 100644
index e870331de79e..000000000000
--- a/media-libs/libextractor/libextractor-1.6.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Library to extract metadata from files of arbitrary type"
-HOMEPAGE="https://www.gnu.org/software/libextractor/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="apparmor +archive +bzip2 ffmpeg flac gif gsf gstreamer gtk jpeg +magic midi mp4 mpeg tidy tiff vorbis +zlib" # test
-
-RESTRICT="test"
-
-COMMON_DEPEND="
- app-text/iso-codes
- dev-libs/glib:2
- media-gfx/exiv2:=
- sys-devel/libtool
- virtual/libiconv
- virtual/libintl
- apparmor? ( sys-libs/libapparmor )
- archive? ( app-arch/libarchive:= )
- bzip2? ( app-arch/bzip2 )
- ffmpeg? ( virtual/ffmpeg )
- flac? (
- media-libs/flac
- media-libs/libogg
- )
- gif? ( media-libs/giflib:= )
- gsf? ( gnome-extra/libgsf:= )
- gstreamer? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- )
- gtk? ( x11-libs/gtk+:3 )
- jpeg? ( virtual/jpeg:0 )
- magic? ( sys-apps/file )
- midi? ( media-libs/libsmf )
- mp4? ( media-libs/libmp4v2:0 )
- mpeg? ( media-libs/libmpeg2 )
- tidy? ( app-text/htmltidy )
- tiff? ( media-libs/tiff:0 )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-# test? ( app-forensics/zzuf )
-RDEPEND="${COMMON_DEPEND}
- !sci-biology/glimmer
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-CVE-2017-17440.patch"
- "${FILESDIR}/${P}-ffmpeg-4.patch"
-)
-
-src_prepare() {
- default
-
- # m4/ax_create_pkgconfig_info.m4 is passing environment LDFLAGS to Libs:
- sed -i \
- -e '/^ax_create_pkgconfig_ldflags=/s:$LDFLAGS ::' \
- -e 's:tidy/tidy.h:tidy.h:' \
- -e 's:tidy/tidybuffio.h:buffio.h:' \
- configure src/plugins/html_extractor.c || die
-
- if ! use tidy; then
- sed -i -e 's:tidy.h:dIsAbLe&:' configure || die
- fi
-}
-
-src_configure() {
- e_ac_cv() {
- export ac_cv_"$@"
- }
-
- e_ac_cv {lib_rpm_rpmReadPackageFile,prog_HAVE_ZZUF}=no
-
- e_ac_cv header_FLAC_all_h=$(usex flac)
- e_ac_cv lib_FLAC_FLAC__stream_decoder_init_stream=$(usex flac)
- e_ac_cv lib_FLAC_FLAC__stream_decoder_init_ogg_stream=$(usex flac)
-
- e_ac_cv header_sys_apparmor_h=$(usex apparmor)
- e_ac_cv header_archive_h=$(usex archive)
- e_ac_cv header_bzlib_h=$(usex bzip2)
- e_ac_cv header_gif_lib_h=$(usex gif)
- e_ac_cv header_jpeglib_h=$(usex jpeg)
- e_ac_cv header_magic_h=$(usex magic)
- e_ac_cv header_mpeg2dec_mpeg2_h=$(usex mpeg)
- e_ac_cv header_tiffio_h=$(usex tiff)
- e_ac_cv header_vorbis_vorbisfile_h=$(usex vorbis)
- e_ac_cv header_zlib_h=$(usex zlib)
- e_ac_cv lib_mp4v2_MP4ReadProvider=$(usex mp4)
- e_ac_cv lib_smf_smf_load_from_memory=$(usex midi)
-
- econf \
- --disable-static \
- --enable-experimental \
- --enable-glib \
- --disable-gsf-gnome \
- $(use_enable gsf) \
- $(use_with gstreamer) \
- $(use_enable ffmpeg)
-}
-
-src_install() {
- default
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}